ArcGIS Web Adaptor 10.9.1: Configuring the Web Adaptor ends up with an “unable to connect” error,

2693
8
Jump to solution
06-13-2022 11:44 AM
JamalNUMAN
Legendary Contributor

ArcGIS Web Adaptor 10.9.1: Configuring the Web Adaptor ends up with an “unable to connect” error,

 

I couldn’t figure out why configuring the Web Adaptor ends up with an “unable to connect” error as per the screenshot below.

 

What could be the issue here?

 

 

Clip_734.jpgClip_735.jpgClip_736.jpg

----------------------------------------
Jamal Numan
Geomolg Geoportal for Spatial Information
Ramallah, West Bank, Palestine
1 Solution

Accepted Solutions
JonEmch
Esri Regular Contributor

@JamalNUMAN 

When installing the web Adaptor, make sure that you choose the 443 binding, this is the https port. In my experince, this is easy to miss especially if you let the Web Adaptor installer handle installation of IIS.  My advice to you is to:

  • Uninstall the current Web Adaptor,
  • Go to IIS, create the 443 binding on your default site with the appropriate certificate (optional, but recommended)
  • Re run the the Web Adaptor installer ensuring to select the https (443) option

This should make it available to be hit over https.

Keep on keeping on!

View solution in original post

8 Replies
BillFox
MVP Frequent Contributor

try using the fully qualified domain name

JamalNUMAN
Legendary Contributor

This is a test machine. It’s used to work this way in the earlier versions of adaptors.

----------------------------------------
Jamal Numan
Geomolg Geoportal for Spatial Information
Ramallah, West Bank, Palestine
0 Kudos
Scott_Tansley
MVP Regular Contributor

if your test machine is not on a domain, then the FQDN equivalent will be something along the lines of https://jamalnuman2.local  always better to use the FQDN when making any form of configuration. 

Does it connect if you just want the root?  What did you call the web adaptor when you installed it?  I haven't seen 'adaptor' used before for the context.

 

Scott Tansley
https://www.linkedin.com/in/scotttansley/
George_Thompson
Esri Frequent Contributor

It looks like you have second level context in the URL: "machinename/adaptor/webadaptorname/server"

 

"If you do not use ArcGIS Web Adaptor in your deployment, ensure that the reverse proxy server's context name only goes one URL level deep. For example, you can have a reverse proxy URL such as https://proxy.domain.com/enterprise, but you cannot have a reverse proxy URL such as https://proxy.domain.com/myorg/enterprise."

https://enterprise.arcgis.com/en/portal/latest/administer/windows/using-a-reverse-proxy-server-with-...

--- George T.
JamalNUMAN
Legendary Contributor

 

My observation is:

 

As the ArcGIS Web Adaptor starts, the link is

http://localhost/adaptor/webadaptor

 

As the “GIS, Image, Workflow Manager, GeoAnalytics or Knowledge Server” option is selected and the “next” button is clicked, the link is redirected to:

https://jamalnuman2/adaptor/webadaptor/server

 

if the https is replaced by http, then it should work

http://jamalnuman2/adaptor/webadaptor/server

 

How can the adaptor be accessed with the https even if the https is not configured as this works for the services directory?

 

http://localhost:6080/arcgis/rest/services

https://localhost:6443/arcgis/rest/services

 

Clip_738.jpgClip_739.jpgClip_740.jpgClip_741.jpgClip_742.jpgClip_743.jpgClip_744.jpg

----------------------------------------
Jamal Numan
Geomolg Geoportal for Spatial Information
Ramallah, West Bank, Palestine
0 Kudos
JonEmch
Esri Regular Contributor

@JamalNUMAN 

When installing the web Adaptor, make sure that you choose the 443 binding, this is the https port. In my experince, this is easy to miss especially if you let the Web Adaptor installer handle installation of IIS.  My advice to you is to:

  • Uninstall the current Web Adaptor,
  • Go to IIS, create the 443 binding on your default site with the appropriate certificate (optional, but recommended)
  • Re run the the Web Adaptor installer ensuring to select the https (443) option

This should make it available to be hit over https.

Keep on keeping on!
JamalNUMAN
Legendary Contributor

Thank you JonEmch for the help. It works fine as per the screenshots below

 

 

Clip_754.jpgClip_755.jpgClip_756.jpgClip_757.jpgClip_758.jpgClip_759.jpgClip_760.jpg

----------------------------------------
Jamal Numan
Geomolg Geoportal for Spatial Information
Ramallah, West Bank, Palestine
JonEmch
Esri Regular Contributor

Awesome! Glad to hear that this worked.

Keep on keeping on!