arcgis server manager redirecting back to login page

3566
9
Jump to solution
07-10-2015 11:04 AM
jaredrodriguez1
New Contributor II

Hello Everyone,

First time blogger.  My problem is with one of my sites.  After I log into the server manager the main page comes up fine.  If I click on any of the tabs (Services, Site, Security, Logs) or sub tabs, i.e. Web Adaptor or Software Authorization, the site redirects be back to the login page which is obviously super annoying.  I tested with both http and https, from different client workstations, different browsers and a clone of the server also does the same thing.  If anyone has any ideas they would be much appreciated.

1 Solution

Accepted Solutions
jaredrodriguez1
New Contributor II

Okay so now I can answer my question.  Daniel was definitely on the write path.  This morning looking at my iis logs under inetpub i noticed that the timestamp on the log entries was very far off from my system time.  So once I synced up my client machine with the server BOOM! works like a champ.  I believe that the authentication token compares itself to the system time so in my scenario it always appeared older than the authentication time set at 60 minutes.  So I believe hypothetically had I increased my shortTimeout value as Daniel said to something extreme like 6000 it would have worked also but obviously keeping all of the computers synchronized is correct.  Anyway hopefully this information can help someone with the same issue in the future also.

View solution in original post

9 Replies
DanielUrbach
Occasional Contributor II

Hi Jared,

If you log into the admin endpoint and go to Security > Tokens, check what the 'shortTimeout' value is set to (it is in minutes).

My guess is this value is set to 1, meaning every minute you are expected to log back in.

If this is the case, you can change this to 30 or 60 depending on your needs.

jaredrodriguez1
New Contributor II

Thanks for the reply.

The shortTimeout is set to 60 and the longTimeout is set to 1440.  Still no joy.

jaredrodriguez1
New Contributor II

Okay so now I can answer my question.  Daniel was definitely on the write path.  This morning looking at my iis logs under inetpub i noticed that the timestamp on the log entries was very far off from my system time.  So once I synced up my client machine with the server BOOM! works like a champ.  I believe that the authentication token compares itself to the system time so in my scenario it always appeared older than the authentication time set at 60 minutes.  So I believe hypothetically had I increased my shortTimeout value as Daniel said to something extreme like 6000 it would have worked also but obviously keeping all of the computers synchronized is correct.  Anyway hopefully this information can help someone with the same issue in the future also.

View solution in original post

MajdoleenO_A__Awadallah
Occasional Contributor III

I am encounter the same issue, thank you for your answer,

I've increased the shorttimeout value to 1200 minutes, but It logs out without respecting the time. I tried the setting below for the admin:

What might be the issue? do you think that I need to increase it to 6000?

Best

MajdoleenO_A__Awadallah
Occasional Contributor III

Also, It tried to increase it to 3000, but this doesn't solve my issue, do I need to configure anything at the level of iis?

Please advice

Best

Majdoleen

lubnajarara_ah
New Contributor III

Dear Majdoleen,

I think you need to stop/ start the arcgisserver service after updating the value

Please let me know if you still have an issue here

I tried to decrease it to 5 min and it work fine

Then stop and start the service

Best,

Lubna

JamalNUMAN
Esteemed Contributor

I applied what you have recommended, Lubna, but the manager logged out in its own!

----------------------------------------
Jamal Numan
Geomolg Geoportal for Spatial Information
Ramallah, West Bank, Palestine
MajdoleenO_A__Awadallah
Occasional Contributor III

Despite the fact that I tried to stop/ start the arcgisserver service after updating the value, the issue persist to exist.

Best

Maajdoleen

JamalNUMAN
Esteemed Contributor

I got same behavior as you Majdoleen. It doesn't respect the time set in the token

----------------------------------------
Jamal Numan
Geomolg Geoportal for Spatial Information
Ramallah, West Bank, Palestine