ArcGIS server 10.4 services stuck in perpetual "stopping" state

6367
8
Jump to solution
08-31-2016 09:56 AM
Kerry_-_AnnHarriott1
New Contributor II

I currently have arcgis server workgroup 10.4.1 installed on my computer and it was working just fine until now, all my services have seemingly "stopped" and i am unable to publish any services; when i try to, i get an error message "server is not ready for publishing.... i checked the server manager and all the services are in "stopping" state. i tried to stop the individual services in server manager and the server will stop the service, however when i restart it i get an error message to "failed to start the server machine {computer name}.Error while starting AppServer. required port {0} already in use". I tried to stop/start the arcgis server service from administrative tools (in control panel) but all options are greyed out so I can't stop or restart the service, i have tried granting all users full control (since i needed administrator access when i first installed server) to the arcgisserver folder, i tried to start the publishing tools GP but i got another error message that it failed to start. i tried to publish my service using the service definition file but i get another message about starting the service (which does not start when i select start service)... my current connection is using https://localhost:6443/arcgis/manager   

I don't want to reinstall, because i fear i will lose my services if i do but if i have to what can I do to ensure my services are there once i create the server manager site?

0 Kudos
1 Solution

Accepted Solutions
RebeccaStrauch__GISP
MVP Esteemed Contributor

Have you installed the

ArcGIS for Server Publishing Patch

Esri Support 10.4 (10.4.1) 

I know that has been helping with many other issue with 10.4.1 "hanging"

...and a list of all the 10.4.x patched

Esri Support 10.4 (10.4.1) 

View solution in original post

8 Replies
JayantaPoddar
MVP Esteemed Contributor

Folder permission could be one among many issues. Close all Applications. Stop the service for ArcGIS Server (services.msc). Grant permission to "arcgis" account for config-store folder. Restart the service for ArcGIS for Server. Allow some time for all the services (map) in ArcGIS Server to start.

If that didn't work, I would need more details about the ArcGIS Server setup (Hardware configuration, Virtual Memory, No. of services running, Min./Max. no. of instances allowed for the services, SSL Certificate, etc.)



Think Location
0 Kudos
RebeccaStrauch__GISP
MVP Esteemed Contributor

Have you installed the

ArcGIS for Server Publishing Patch

Esri Support 10.4 (10.4.1) 

I know that has been helping with many other issue with 10.4.1 "hanging"

...and a list of all the 10.4.x patched

Esri Support 10.4 (10.4.1) 

View solution in original post

Kerry_-_AnnHarriott1
New Contributor II

looks like running the patch helped...thanks so much

0 Kudos
RebeccaStrauch__GISP
MVP Esteemed Contributor

Glad it worked, If the patch did fix the issue, don't forget to mark the answer as correct so this thread can be closed and others will find the answer if the have the same issue.

AvinashPatel1
Occasional Contributor III

Hi,

No this issue not resolved with updation of latest patch,

Only Slowness issue in map services publishing is resolved. 

Apart from this we have still facing recycling stopping/stop issue in map services.

Some time its services are not started and shows locked with admin.

In this case we need to restart ArcGIS server services to resolve our issue and make maps are avilabe and running.

Thanks!

AaronMielke1
New Contributor II

I agree that the patch does not fix the issue. Have you come across anything that does?

AvinashPatel1
Occasional Contributor III
AaronMielke1
New Contributor II

We had the same problem and it seems it was related to the number of services we had running (we had 380) and the limited computer resources (RAM).  After performing an install or software update the ArcGIS Server Service is restarted; this causes all of your services to startup at once. A process begins running on the server for each map/feature/GP service. Each one of these processes requires about 100MB of RAM. As the processes spin up you can watch Window Task Manager and see the number of process tick up as well as the percent of the RAM used. Eventually it gets to 99% RAM and things just stall out. Something about maxing the RAM out seems to causes the ArcServer software to fail.

The solution that was suggested to me was to stop the ArcGIS Server service, then manually go into each of the services json file and change the "configuredState" from "STARTED" to "STOPPED".  The json file for each service can be found in the config-store, see location below. I was told that by doing this it would prevent these process from starting up the next time I restarted the ArcGIS Server Service. After modifying the JSON of 300+ services I ran the install and chose "Repair". Once the install/repair was complete the ArcGIS Server service came back online and I was anticipating none of the processes would start up, that was not the cases.  I immediately started seeing processes spin up. Before the RAM was maxed out I stared manually killing the ArcServer processes in Windows Task Manager. I actually ran a kill script that killed all of the ArcServer processes.  After that everything seemed to be running fine. I don't fully understand the problem or the fix but it seemed like being able to prevent my server from running out of resources was the solution. 

 

- config-store

   - services

        - "Name of folder containing subset of services"

             - "Name of Service"

                  - "Name of Service".json