ArcGIS Portal keeps asking for login details when using the alias URL

3032
4
05-16-2019 02:04 AM
WimBergkamp
New Contributor II

I keep getting a pop-up to sign into ArcGIS Enterprise/Portal whenever I want to add a map from ArcGIS Online/in My Organization settings/ArcGIS Insights, even though I'm signed in already. This only happens when I use the alias URL instead of https://<webadaptorhost>.<domain>.com/<webadaptorname>. I did add the alias in my GetAppID for arcgisonline and arcgisInsights in the portaladmin interface (arcgis/portaladmin/security/oauth/), but probably I have to do something else also. Can anybody help me further?

Thanks in advance

Tags (2)
4 Replies
StevenRamirez
Esri Contributor

Hi Wim, 

 Thanks for posting this question to GeoNet. Does this happen when adding a tiled basemap service from AGOL to a webmap in Portal? If so, then most likely the credentials were not cached/no longer valid, when added as an item to Portal.  To correct this you would need to remove the existing item from Portal. Then re-add the service as an item. This should prompt Portal to check if the service is secured and open a dialog box asking if you wish to store credentials. To prevent users when using this item you will need to select 'Store credentials' and provide your AGOL credentials. I hope this information helps. 

0 Kudos
WimBergkamp
New Contributor II

Hi Steven,

no it does not happen when adding a tiled basemap. It happens when I go to my organization -> edit settings, or when adding a new workbook in Insights. Sometimes it happens when adding a map, but this only happens on the created alias URL: portal.organization.com. Asking for credentials doesnt happen when I use the machine-url: https://<webadaptorhost>.<domain>.com/<webadaptorname>. I Dont think it has something to do with the stored AGOL credentials, but with something else. It looks like it did not store my username/password of portal? 

0 Kudos
CodyMarsh
Occasional Contributor

Hello Wim,

Do you know if you have set the WebContextURL property in the Portal Admin endpoint? The process on how to do so can be found here: https://enterprise.arcgis.com/en/portal/latest/administer/windows/using-a-reverse-proxy-server-with-....

- Cody

0 Kudos
MichaelSchoelen
Occasional Contributor III

I've seen this problem before when the Web Adaptor had the machine name listed in Web Adaptor URL rather than the alias used by the end users.

https://community.esri.com/thread/120618

1. login to portal admin : https://yourmachinename.domain:7443/arcgis/portaladmin

2. click system > web adaptors > you will find your webadaptor name. click the web adaptor name, you will get the url like this https://yourmachinename:7443/arcgis/portaladmin/system/webadaptor/cc1dbd26-03ac0497c-69cbd8fc6cc8 (this is random id, maybe different in your machine)

3. in the browser append /edit to the end of the URL like this : https://yourmachinename:7443/arcgis/portaladmin/system/webadaptor/cc1dbd26-03ac0497c-69cbd8fc6cc8/edit then push enter.

4. edit Web adaptor URL, change with your domain. by default the url is machinename > click web adaptor. the portal is restarted, wait for the portal to restart before proceeding.

0 Kudos