ArcGIS Enterprise Term License expired - can't upgrade to 10.9.1

125
1
Jump to solution
05-27-2022 04:39 AM
PI-GIS
by
New Contributor II

Hello everyone,

we have a single machine ArcGIS Enterprise deployment and our term license expired recently. We bought new licenses and are now trying to upgrade from 10.8.1 to 10.9.1 but the Portal upgrade is constantly failing in the Create Initial Administrator Account step with the following error message:

There was an error when attempting to upgrade the existing portal.
Index Service configuration failed.

For more information, please view the log messages located in the content directory specified during setup (C:\arcgisportal\logs).

The problem seems to be very similar to this thread. Our VM has 8 virtual processors.  We also do a server restart and clear the browser cache before the  Create Initial Administrator Account step. The account used to run the service, specified during the installation, is a domain admin account. ArcGIS Web Adaptor for the Portal was uninstalled prior to upgrade as specified in this official ESRI guide for ArcGIS Enterprise Upgrade that we are following. 

There are few errors in the logs (logs attached).

One of the errors in the logs is about Portal not being able to connect to identity store as one or more of the connection parameters are incorrect. I cant update the configuration since, when I open the Portal Administrator Directory, I only have the options to UpgradeValidate License and REST. When I click on REST this is what I get:

{
    "status": "error",
    "messages": ["The portal site has not been upgraded. Please upgrade the site and try again."],
    "isUpgrade": true,
    "resources": ["license"],
    "isPortalLicensed": true,
    "isLicenseFileRequired": true,
    "isUserTypeLicensing": true,
    "version": "10.9.1"
}

So because my license expired, unless there is another option to edit the identity store configuration other than trough the Portal Administrator Directory, I'm unable to update the user and password used for querying Active Directory?

Another error that shows up is about failing to configure and start a spatiotemporal big data store. We only had a relational and tile cache data stores configured, so I guess this error can be ignored?

The third error that shows up and for which I could not find any useful info on the web is:

The process monitor did not find the connection to the configuration store.
The site may not have been initialized. After the site is initialized, the check for database processes will be reattempted.

 

We really would like to keep and upgrade the current deployment without uninstalling and setting up a new one if possible.

Any help would be appreciated.

0 Kudos
1 Solution

Accepted Solutions
PI-GIS
by
New Contributor II

I'll post this update in case anyone has the same problem. Turns out the issue was due to slow HDD speed. As we moved the VM-s to SSD-s I was able to successfully upgrade the portal.

View solution in original post

0 Kudos
1 Reply
PI-GIS
by
New Contributor II

I'll post this update in case anyone has the same problem. Turns out the issue was due to slow HDD speed. As we moved the VM-s to SSD-s I was able to successfully upgrade the portal.

0 Kudos