Select to view content in your preferred language

ArcGIS Enterprise 11.1 is not printing features with custom print widget

8364
51
05-05-2023 10:56 AM
AbiDhakal
Occasional Contributor III

Hello. I need your help friends.

I just installed ArcGIS Enterprise 11.1 yesterday and found out that my custom print widget is not able to print feature service features. The pdf map from the print widget comes out blank with just the base layer and no features on it.  It prints image service and tile service features, but not feature service features. I'm in distress. All our agency application are built using Web AppBuilder applications and they have feature service in them because we want folks to be able to edit features, however when printing the features do not show up. This issue will render our enterprise useless.

Please help. I'm sure one of you have a resolution or work around.

Thank you,
Abi

51 Replies
BillFox
MVP Frequent Contributor

did you do an in-place upgrade?

do you see any printing errors or access errors in the portal or arcgis server logs?

is this a stand alone ArcGIS Server for printing?

0 Kudos
AbiDhakal
Occasional Contributor III

@BillA 

I did an upgrade with Esri tech support.

This is the error log from the Server:
Error executing tool. Export Web Map : Failed to create layer from service at https://gis.forestry.alabama.gov/arcgis/rest/services/AFCEnterprise/StandMapping/FeatureServer/0. Failed to execute (Export Web Map).

Yes, on this machine I have Portal, Server, Web Adaptor for both Portal and Server and DataStore.

Thank you very much,
Abi

 

0 Kudos
AbiDhakal
Occasional Contributor III

@BillFox I have logged a BUG - 000151919 in October of last year when it did this for one on my applications, however the rest of my applications were working just fine so I did not think much of it. Now, after installing ArcGIS Enterprise 11.1 it is doing this for all the applications.

Thank you,
Abi

0 Kudos
MichaelTorbett
Occasional Contributor II

Following this post. I was planning on upgrading to ArcGIS Enterprise 11.1 next week, but will hold off until I see if a solution to this problem is available.

BillFox
MVP Frequent Contributor

if possible, can you install a stand alone ArcGIS Server (not federated) just for printing? and then have your print widget use its printing url

0 Kudos
Pei-SanTsai
New Contributor III

My custom print services (secured and non-secured) published from ArcMap years ago are on my standalone ArcGIS Server.  I can't get any ESRI basemap printed correctly.  I just upgraded from 10.8.1 to 10.9.1, tested my non-secured print service, it worked with Map Viewer but not in the web appbuilder print widget.  I'm still in progress of figuring out the issue.  Also, I can't get secured print service published from ArcGIS Pro to work, any app with secured map service will get an error when I try to print.  I know in the past when I published my secured print service, I have an admin user account & password saved with the service but I don't see that option available in ArcGIS Pro.  

0 Kudos
AbiDhakal
Occasional Contributor III

@BillFox I do not have another machine to do that, Bill. I hope someone in the community picks up this conservation and has an environment that you suggest and gives us the answer to your question.

Thank you,
Abi

0 Kudos
BillFox
MVP Frequent Contributor

what release did you upgrade from?

0 Kudos
AbiDhakal
Occasional Contributor III

@BillFox 

From ArcGIS Enterprise 11.

0 Kudos