a valid arcgis license manager for your licensing portal could not be found on the specified host

653
4
Jump to solution
02-28-2022 02:41 AM
Ikebana
New Contributor II

Hello!

Just out of blue a customer started to report that they can't get a license in Pro from their license server. I have attached the error message that I have not seen before.

"a valid arcgis license manager for your licensing portal could not be found on the specified host"

 

- The connection works from within the server.

- I have looked in portal admin so that license is pointed to correct server name and port 27000

- I can connect to the public IP and port 27000 and get a valid response in powershell.

- I've changed the IP in portaladmin to a local IP and connected to the portal outside from server with vpn activated and that also works well

 

It seems that all connection from the "outside" gets blocked by something but nothing have changed on the server.

Any ideas? 🙂

0 Kudos
1 Solution

Accepted Solutions
AmnoyAm
Esri Contributor

First of all, go back to the portal admin and change the license manager server back to the external name or IP address.  Then you want to check which ports are being used by the license manager.  Go to the license manager installation directory and open service.txt in Notepad or any other editing app.  The SERVER line should have port 27000 which you've pointed out.  This is the port for the lmgrd.exe.  There should be another port specified in the VENDOR line.  Example:  VENDOR ARCGIS port=27002.  In this case, the ArcGIS.exe is using port 27002.  You may have a different port in your environment.  If not listed, you will need to specify the port.  Once verified, you must open the firewall for both ports between the license manager server and the client workstation.

View solution in original post

4 Replies
MarcusAndersson
New Contributor III

Hi!
Have you conscidered compatibility for different Pro-versions? We had some issues with this as we upgraded clients to 2.9 and then could not connect to the License Manager. Solution was to upgrade the License Manager, as I recall it anyways.. 🙂
More info can be found here:
Supported software products—License Manager Guide | Documentation (arcgis.com) 

0 Kudos
Ikebana
New Contributor II

I have latest version on license manager and Pro. So it should not be the problem here.

AmnoyAm
Esri Contributor

First of all, go back to the portal admin and change the license manager server back to the external name or IP address.  Then you want to check which ports are being used by the license manager.  Go to the license manager installation directory and open service.txt in Notepad or any other editing app.  The SERVER line should have port 27000 which you've pointed out.  This is the port for the lmgrd.exe.  There should be another port specified in the VENDOR line.  Example:  VENDOR ARCGIS port=27002.  In this case, the ArcGIS.exe is using port 27002.  You may have a different port in your environment.  If not listed, you will need to specify the port.  Once verified, you must open the firewall for both ports between the license manager server and the client workstation.

Ikebana
New Contributor II

So the solution was to find the right vendor port that was lost during an upgrade of license manager. I also changed the hostname to external name. Thanks!

0 Kudos