10.5 to 10.6 w/ Portal Upgrade

753
7
04-03-2018 06:22 AM
AndrewMilanes
Occasional Contributor II

What is the proper upgrade procedure to go from 10.5 without Portal to 10.6 with Portal?  Do I install 10.6 Portal and Web Adapter then upgrade 10.5 Server and Web Adapter?

Tags (1)
0 Kudos
7 Replies
RandallWilliams
Esri Regular Contributor

Personally, I'd upgrade the GIS Server to 10.6, then install Portal/Web adaptor/Data Store 10.6 and then Federate.

RebeccaStrauch__GISP
MVP Esteemed Contributor

And if you don't plan to federate, similar.

Upgrade Server to 10.6.  You will have to uninstall and reinstall the web adaptor I believe.

Then you can install and setup Portal and the web adaptor.  Federation is not mandatory (we have not done it)

PaulHoeffler2
New Contributor II

All of the upgrade steps are laid out for each version of ArcGIS Enterprise here:

Upgrade your ArcGIS Enterprise portal—Portal for ArcGIS (Windows) Installation Guide (10.5) | ArcGIS... 

We attempted an upgrade of our system over the course of twenty hours in the last two business days, but it failed - having backups in place, as mentioned in the above documentation, should be considered a must prior to attempting an upgrade of these applications.

AndrewMilanes
Occasional Contributor II

I don't have Portal installed, so there will be no upgrade of that.

0 Kudos
AndrewMilanes
Occasional Contributor II

So Server upgraded and Portal installed fine.  Then when I tried to upgrade Data Store I ran into issues.  I ended up deleting the Data Store and re-installing.  This is the error I'm getting now:

Error registering data source '{"path":"/enterpriseDatabases/AGSDataStore_ds_g9qk4les","type":"egdb","clientPath":"","make":"ArcGIS Data Store","provider":"ArcGIS Data Store","info":{"isManaged":true,"provider":"ArcGIS Data Store","dataStoreConnectionType":"serverOnly","connectionString":"PASSWORD=yAu=vG47E1I=;SERVER=GISSERVER.ES2.LOCAL;INSTANCE=sde:postgresql:GISSERVER.ES2.LOCAL,9876;DBCLIENT=postgresql;DB_CONNECTION_PROPERTIES=GISSERVER.ES2.LOCAL,9876;DATABASE=db_vixze;USER=hsu_riidy;VERSION=sde.DEFAULT;AUTHENTICATION_MODE=DBMS","connectionStringHA":"PASSWORD=yAu=vG47E1I=;SERVER=ds_g9qk4les;INSTANCE=sde:postgresql:DSID=ds_g9qk4les;DBCLIENT=postgresql;DATABASE=db_vixze;USER=hsu_riidy;VERSION=sde.DEFAULT;AUTHENTICATION_MODE=DBMS","JDBCConnection":{"name":"PostgreSQLonGISSERVER.ES2.LOCAL","factory":"org.apache.tomcat.jdbc.pool.DataSourceFactory","driverClassName":"org.postgresql.Driver","url":"jdbc:postgresql://GISSERVER.ES2.LOCAL:9876/db_vixze","username":"hsu_riidy","password":"yAu=vG47E1I=","initialSize":0,"minIdle":0,"timeBetweenEvictionRunsMillis":10000,"minEvictableIdleTimeMillis":20000,"testOnBorrow":true,"validationQuery":"SELECT 1"},"machines":[{"name":"GISSERVER.ES2.LOCAL","adminURL":"https://GISSERVER.ES2.LOCAL:2443/arcgis/datastoreadmin/","dbPort":9876,"platform":"Windows","role":"PRIMARY"}]}}'. Registration of database '/enterpriseDatabases/AGSDataStore_ds_g9qk4les' is incomplete. Failed to get connection string from System/PublishingTools GP service.

AndrewMilanes
Occasional Contributor II

I'm using SQL Server so I'm not sure why postgresql is listed there.

0 Kudos
MichaelSchoelen1
New Contributor II

Andrew, ever get a solution to this? I'm doing a re-install of 10.5.1 and I'm suddenly getting this message on a machine that has worked before. 

P.S. ArcGIS Data Store uses Postgres, regardless of what you are using for an enterprise database otherwise.

0 Kudos