Changes to SDE data Not Showing in Portal Hosted Feature Layer

578
12
01-05-2021 11:27 AM
LeviCecil
Occasional Contributor III

I have a floor plan dataset in an sde. We've published this as a hosted feature layer in our Portal and copied it to the federated Server. I'm making edits in the data, but they are not showing up in my Field Maps app which contains the hosted feature layer, even after refreshing the map and signing out and back in. We've just set up our Enterprise, so I'm not totally familiar with exactly how to configure everything. We were using a standalone Server before, and this process worked.  

Reply
0 Kudos
12 Replies
LeviCecil
Occasional Contributor III

It just publishes to a regular folder (not hosted) and "replaced" is highlighted. 

Reply
0 Kudos
LeviCecil
Occasional Contributor III

Still trying to figure this out. I found this Python method for overwriting hosted feature services. It works perfectly on our test portal, but with the same dataset on our production portal I get this error from Python: Exception: Unable to publish item.
This service definition file was created for an ArcGIS Server site and must be uploaded directly to an ArcGIS Server site through ArcGIS Server Manager or ArcMap.
(Error Code: 400) 

Reply
0 Kudos
LeviCecil
Occasional Contributor III

Still trying to figure this out. I've been manually overwriting the hosted feature service when there are changes to the sde data. We discovered today that all the records generated in the related table through Survey123 have been deleted, going back a week and a half. I've tried publishing this data every which way and it's never a referenced data set, just a copy. The sde it comes from is registered with the Portal, so I don't understand what's missing. 

Reply
0 Kudos