Where is the "replace" option for a vector tile layer in Portal?

680
6
07-28-2020 11:27 AM
KaseyCox
New Contributor II

I have created an updated vector tile package, uploaded onto my Portal, but I cannot find the "replace" option that allows the old layer to be replaced without having to manually replace it in all of my maps.  

0 Kudos
6 Replies
JonahLay
Esri Contributor

Hi Kasey,

What version of enterprise are you publishing to? Did you publish a hosted vector tile layer from the package?

Please see the following documentation for more information: Manage hosted tile layers—Portal for ArcGIS | Documentation for ArcGIS Enterprise 

Best,

Jonah

0 Kudos
KaseyCox
New Contributor II

10.6.0, and yes: Vector Tile Package uploaded, and published to a hosted Tile Layer.  I just cannot find the "replace" option in Portal.  I am able to do it though AGOL just as described in online help files, but not in Portal.

0 Kudos
KaseyCox
New Contributor II

I think the problem might be that the documentation is not separate for 10.6.0 and 10.6.1 and the replace functionality doesn't come into play until 10.6.1.    :(   got any tips on a workaround until I can upgrade?  I will be researching!

Thank you for your help Jonah!

0 Kudos
JonahLay
Esri Contributor

You can use ArcGIS Pro to replace a vector tile layer: Replace a vector tile layer—ArcGIS Pro | Documentation 

KaseyCox
New Contributor II

THANK YOU JONAH!  i can make that work until we do an upgrade!!!  

ahargreaves_FW
Occasional Contributor II

There is an inconsistency in the way this is implemented at 10.9.1. 

If I use Pro > Share > Publish a web layer and then configure it to copy all data to portal, make me a vector tile layer and an associated feature service I get NO replace layer option when looking at the item in portal.

If I use Pro > create vector tile package then share the package and publish it I DO get a replace layer option.

@DavidWatkins is this by design?

0 Kudos