Sharing issue from items @ 11.1

778
3
Jump to solution
05-22-2023 10:02 PM
FraserHand
Occasional Contributor III

Hi there,

We have just upgraded from 10.9.1 --> 11.1.

There is a builtin portal user account which has a large amount of content and owns a large number of groups ~163. What we are seeing is post upgrade when we try to share from an item we see this:

FraserHand_0-1684815926648.png

 

even though this user does own and belong to multiple groups.

When attempting to share I see a request to get the user back

https://someportal/arcgis/sharing/rest/community/users/someuser?f=json&token=atoken

which returns the user details and their groups - then there are 2 follow up requests

//someportal/arcgis/sharing/rest/community/groups?f=json&q=(isviewonly%3Afalse%20OR%200235a214dca848ffb1db46b3df43c1a8%20OR%200cf8f0139e3f4785bca2015b923631f2%20OR%201941d0b595624011b18a746e6f3bab64%20OR%201e45834c67264335bb318b404c7401cd%20OR%2024d81913f7c84783a421efd4e03ed211%20OR%20496c19eeb06e40c6b73c6c329c6aae90%20OR%204ee3fa9320e54c808e05f3b73401789a%20OR%206601aff4b2bd4ccdafb24e786be5a573%20OR%2079f2e1d7018d4cf8a2448c72933dcc68%20OR%207d51672c405c47f2bc2639dd33bbd52f%20OR%207da67743d70948fcaef09d70c72aaf48%20OR%20806e54dc89694e9a9747fc37634dfa21%20OR%20824f7ee897034d68b5fe55c308f64cd8%20OR%2082b8bf57a3cd455f94ee6ac6a5caa45a%20OR%20888f2e6a53ab4c45afa33a1e2d9c0703%20OR%209db4dff2c9614023b7a122de5ddf3f13%20OR%209f37e19c926448de823607df2c94e87c%20OR%20a3468dfb497c4983b7a33c2d8517f680%20OR%20a85c75a39ebf4fcf9e227bf13ebc2785%20OR%20ac42d9cb72574da89111899f90544c47%20OR%20acf42ba560014311ad7ddff88f6b23ee%20OR%20b60bc72331ed4848aad1073a56b209e3%20OR%20b6f5b7cf4c9e42b0922e531ad090dba1%20OR%20b7d32629a08244ceb5640b0d032c9bd3%20OR%20bc05396c45ca4475a1d9d36936e47a96%20OR%20bea88b16ee234f1384b2358f9cc0a4eb%20OR%20c14503b3fc664d22b5938a270d7fc747%20OR%20d6e17013375d4e9aa49ee21cf3c8acf7%20OR%20d7c3e093cb9d410daa83cf487e14366a%20OR%20da54c17247444483bc2c32105a274636%20OR%20dd165b4388024970ab7013c17da8f2b8%20OR%20e51ca3e60c3e4540805ff0216c54a0d3%20OR%20eeccca78191c41cda09dd1e7bc2fd39e%20OR%20f1a3680d317046d3a7b58d9f77c7b145%20OR%20f42c32153c70478aa2625973ea3016d8)&num=100&sortField=title&sortOrder=asc&start=1&searchUserAccess=groupMember&searchUserName=someuser&token=sometoken 

this returns

{"total":0,"start":0,"num":0,"nextStart":0,"results":[]}

and it duplicates 

//someportal/arcgis/sharing/rest/community/groups?f=json&q=(isviewonly%3Afalse%20OR%200235a214dca848ffb1db46b3df43c1a8%20OR%200cf8f0139e3f4785bca2015b923631f2%20OR%201941d0b595624011b18a746e6f3bab64%20OR%201e45834c67264335bb318b404c7401cd%20OR%2024d81913f7c84783a421efd4e03ed211%20OR%20496c19eeb06e40c6b73c6c329c6aae90%20OR%204ee3fa9320e54c808e05f3b73401789a%20OR%206601aff4b2bd4ccdafb24e786be5a573%20OR%2079f2e1d7018d4cf8a2448c72933dcc68%20OR%207d51672c405c47f2bc2639dd33bbd52f%20OR%207da67743d70948fcaef09d70c72aaf48%20OR%20806e54dc89694e9a9747fc37634dfa21%20OR%20824f7ee897034d68b5fe55c308f64cd8%20OR%2082b8bf57a3cd455f94ee6ac6a5caa45a%20OR%20888f2e6a53ab4c45afa33a1e2d9c0703%20OR%209db4dff2c9614023b7a122de5ddf3f13%20OR%209f37e19c926448de823607df2c94e87c%20OR%20a3468dfb497c4983b7a33c2d8517f680%20OR%20a85c75a39ebf4fcf9e227bf13ebc2785%20OR%20ac42d9cb72574da89111899f90544c47%20OR%20acf42ba560014311ad7ddff88f6b23ee%20OR%20b60bc72331ed4848aad1073a56b209e3%20OR%20b6f5b7cf4c9e42b0922e531ad090dba1%20OR%20b7d32629a08244ceb5640b0d032c9bd3%20OR%20bc05396c45ca4475a1d9d36936e47a96%20OR%20bea88b16ee234f1384b2358f9cc0a4eb%20OR%20c14503b3fc664d22b5938a270d7fc747%20OR%20d6e17013375d4e9aa49ee21cf3c8acf7%20OR%20d7c3e093cb9d410daa83cf487e14366a%20OR%20da54c17247444483bc2c32105a274636%20OR%20dd165b4388024970ab7013c17da8f2b8%20OR%20e51ca3e60c3e4540805ff0216c54a0d3%20OR%20eeccca78191c41cda09dd1e7bc2fd39e%20OR%20f1a3680d317046d3a7b58d9f77c7b145%20OR%20f42c32153c70478aa2625973ea3016d8)&num=100&searchUserAccess=groupMember&searchUserName=someuser&token=sometoken 

with

{"total":0,"start":0,"num":0,"nextStart":0,"results":[]}

It seems to be the number of group ids in the query with the ORs - if you drop it down (change the query say from postman then it works as expected (remove a bunch of the OR id OR id etc).

The other thing I saw is if you move some of the existing groups to another owner then the item sharing works - if you move them back it stops working - this was at around 60 groups. This only seems to be with existing groups / users - as I created a new user and 300 test groups that they owned and sharing worked as expected.

I'm wondering if the sharing API is throwing an internal exception and just returning a default response rather than the error. I'm digging into the tomcat logs to see if anything is in there but I suspect the exception if there is one has already been swallowed.

Nothing in portal logs.

Has anyone come across this before?

Thanks

Fraser

1 Solution

Accepted Solutions
MarleyGeddes
Esri Contributor

@FraserHand - I believe the issue you are seeing is the same as that reported here: https://community.esri.com/t5/arcgis-enterprise-portal-questions/portal-for-arcgis-11-1-can-no-longe...

If the member owns or manages more then 30 viewOnly groups, which are groups that are configured to only allow the group owner or managers to contrubte to, then the query to fetch groups will fail. 

Esri support has a defect for this issue, BUG-000158232, and the development team is looking into this. If you have Esri Support, then I encourage you to request to be added to this defect and to share your specific workflow / scenario with the support team.

View solution in original post

0 Kudos
3 Replies
MarleyGeddes
Esri Contributor

@FraserHand - I believe the issue you are seeing is the same as that reported here: https://community.esri.com/t5/arcgis-enterprise-portal-questions/portal-for-arcgis-11-1-can-no-longe...

If the member owns or manages more then 30 viewOnly groups, which are groups that are configured to only allow the group owner or managers to contrubte to, then the query to fetch groups will fail. 

Esri support has a defect for this issue, BUG-000158232, and the development team is looking into this. If you have Esri Support, then I encourage you to request to be added to this defect and to share your specific workflow / scenario with the support team.

0 Kudos
FraserHand
Occasional Contributor III

Thanks for the reply and the bug number - appreciate it. We'll get something logged and attached to the bug number. The reference thread is almost identical t my day yesterday 😃

Thanks

Scott_Tansley
MVP Regular Contributor

Hey Fraser, wait until you come across this one:  https://community.esri.com/t5/arcgis-enterprise-questions/arcgis-web-adaptor-11-1-app-pool-freezes/m...  It's a doozy...  

Scott Tansley
https://www.linkedin.com/in/scotttansley/
0 Kudos