set the default date format for my portal

810
7
04-22-2020 02:46 PM
CarolynMilland1
New Contributor II

Whenever I publish or overwrite a service, the date format defaults back to US MM/DD/YYYY, so, I have to change it every time I update a service. My language and date format is set to the correct region in the My Organisation settings, but it makes no difference. Am I missing something? Can I set the date/time format so that it is set to my region? ie: DD/MM/YYYY

7 Replies
AngelaDeegan
Occasional Contributor

Yes, I've noticed whenever I publish or overwrite a service, all the date attributes in popups revert to a format that includes a time component (which we don't want). And we have to go through each popup and individually uncheck the "Show Time" box in the "Configure Attributes" window in the map. It would really help if there was a global setting for this.

TimMinter
Occasional Contributor III

I agree.  Thumb this up if you're willing - https://community.esri.com/ideas/17706 

AngelaDeegan
Occasional Contributor

Thanks. That issue is related to this, but a bit different. We actually have a a gnarly situation within our GIS our date fields related to time zones - with different scenarios for the following in both Pro and Portal:

  • editor tracking date fields
  • "regular" date fields where the values are from data that we imported from our old (Smallworld) GIS
  • "regular" date fields which we're now populating in Pro

Once we've got a better handle on how to resolve our issues I'll be in a better position to know whether the idea you posted would be likely to work in a case like ours.

by Anonymous User
Not applicable

I think as a community we need to have something like this idea

ESRI default date JSON display format across entire suite of platforms 

JackFanZhang
New Contributor III

Having the same issue as of Dec 2021. just wondering if ESRI is ever going to notice that the default datetime format MM/DD/YYYY is causing some headache to users that outside USA.

İSMAİLGÖKDUMAN
New Contributor II

I HAVE THE SAME PROBLEM, IN THE PRINTING SERVICE THE DATE FORMAT RECEIVED FROM THE PORTAL COMES AS MM/DD/YYYY NO SOLUTION?

Tags (1)
0 Kudos
İSMAİLGÖKDUMAN
New Contributor II

czm.png

Copying the date format from control panel-region settings for all users and devices solved my problem.