Service configuration failed after fresh install of Portal 10.7.1

318
2
03-06-2020 08:03 AM
RyanBumm
New Contributor II

After creating a new portal, I get the error message “There was an error creating your initial administrator account. Index Service Configuration Failed.” In the portal logs it is failing with the error “Attempt to configure data store failed.. Extended error message: Failed to grant file permission.” This is a fresh Portal install so there is no data store yet.

I am using a domain service account which is an administrator on the server. The portal content directory is set to C:\arcgisportal\content, and it seems to be creating the items as expected.

In the Event Viewer Application logs I’ve noticed some PostgreSQL events around the same time that the portal error occurs. One is “FATAL: role "serviceaccount" does not exist

What could be causing this?

0 Kudos
2 Replies
JonathanQuinn
Esri Frequent Contributor

We use ArcGIS Data Store code within Portal for ArcGIS, so that's what the "data store" part of that message is telling you. Does the service account have read/write access to the C:\arcgisportal folder? To rule out any permissions problems, can you try to give the service account full control of that directory? It'll want to write a few files/folders to C:\arcgisportal\index and C:\arcgisportal\dsdata. There are logs under C:\Program Files\ArcGIS\Portal\framework\runtime\ds\usr, they may have some information that is useful.

0 Kudos
RyanBumm
New Contributor II

It looks like the service account already has full control to C:\arcgisportal. I checked in C:\Program Files\ArcGIS\Portal\framework\runtime\ds\usr but the folder is empty.

0 Kudos