Reconfiguring WebAdaptor for Portal

1464
4
Jump to solution
10-07-2016 01:32 AM
PanGIS
by
Regular Contributor

Hi guys,

I am having a huge headache with my portal. hope you can help me in finding the solution.

after having installed portal and the two web adaptors for server and Portal (all the setups for 10.3.1) I cannot access the portal through the web adaptor.

the link https://FullNameOfPC/webadaptorname gives me the error:

"Request is not available in this context"

I can access the Portal through the 7443 but not the webadaptor.

Same for Portaladmin and Sharing/Rest

From PortalAdmin, the webadaptor seems to be registered.

I would probably need to reconfigure the webadaptor but I am not really sure how should I do.

Could you give me a hint?

I thought to unregister and then register again or uninstall and install again

(At the  moment, since this is still a testing environment, the Certificate is a self signed one)

Thanks.

Tags (2)
0 Kudos
1 Solution

Accepted Solutions
PaulDavidson1
Regular Contributor

If Jayanta's suggestions don't work, I'd uninstall and reinstall the web adaptor for Portal. 

If it were me and it's the Test env, I'd probably uninstall both Server and Portal WAs and reinstall them.

If you can, I'd also:

  • Use a  CA cert.  I've had issues that go away when we switched over from the self-signed cert. I doubt that's the problem here though.
  • Install with 10.4.1  Lots of improvements over 10.3.1

Since it sounds like your just starting to setup a Portal, I'd suggest looking at the Esri Chef Cookbooks for deploying a Full Stack Web GIS on a single machine.  The benefits far outweigh the learning curve.

View solution in original post

4 Replies
JayantaPoddar
MVP Esteemed Contributor

I don't have much idea, but did you check/configure .NET trust level in IIS.

Configuring the .NET Trust level in IIS

Before you can configure the ArcGIS Web Adaptor with ArcGIS Server, you must set the .NET Trust level of the Web Adaptor application to Full in IIS. After configuring, you can set the Trust level of the application back to the original level and access your server through the Web Adaptor as normal.

If that doesn't solve the issue, try changing the DefaultAppPool Setting from IIS to Classic App Pool Setting.

http://mvolo.com/iis7-integrated-mode-request-is-not-available-in-this-context-exception-in-applicat...



Think Location
JonathanQuinn
Esri Frequent Contributor

I'd start with including home or sharing at the end of the URL to make sure it's not working right:

https://<portal_webadaptor_machine>/<webadaptorname>/home/

https://<portal_webadaptor_machine>/<webadaptorname>/sharing/

The web adaptor may not redirect correctly if you just go to https://<portal_webadaptor_machine>/<webadaptorname>/.

Next, you can try reconfiguring the web adaptor through your browser:

Configuring ArcGIS Web Adaptor—Installation Guides (10.3 and 10.3.1) | ArcGIS for Server 

The link includes ArcGIS for Server in the title but it points to the page for registering the Portal web adaptor.

PaulDavidson1
Regular Contributor

If Jayanta's suggestions don't work, I'd uninstall and reinstall the web adaptor for Portal. 

If it were me and it's the Test env, I'd probably uninstall both Server and Portal WAs and reinstall them.

If you can, I'd also:

  • Use a  CA cert.  I've had issues that go away when we switched over from the self-signed cert. I doubt that's the problem here though.
  • Install with 10.4.1  Lots of improvements over 10.3.1

Since it sounds like your just starting to setup a Portal, I'd suggest looking at the Esri Chef Cookbooks for deploying a Full Stack Web GIS on a single machine.  The benefits far outweigh the learning curve.

View solution in original post

PanGIS
by
Regular Contributor

Hi guys, thank you,

I solved with a re-installation.

Jayanta

I've checked the 1^ link and the trust level was set on full trust level (automatically I would say, since I never changed that).

2^, to be honest it sounded little chinese for me,   I have asked for help, but still waiting.

Jonathan

I've tried with all the possible urls, same as before.

Than I tryied to reconfigure the portal and the link "https://webadaptor.domain.com/arcgis/webadaptor"

gave me "page not found"

If I can't access the web adaptor page I can't reconfigure. (see below, probably I made a mistake when I configured the first time.

Paul

I've uninstalled and reinstalled. Now it works.

One thing about it, I am on windows 2008 standard.

The webadaptor can't be installed twice (tried on Windows 8.1 and it worked, here I couldn't) I had to use this workaround: https://community.esri.com/thread/113961 

I am quite sure I made a little mistake when I created the duplicate (probably I copied the sites after the registration of the WA with the server) that's why I could not access the sites via WA.

Can't install the 10.4 I don't have the minimum requirements.

A day, when I have time I will use the cookbook. I am curious to see how it works.

Thanks.