Portal for ArcGIS - Pop Up Mismatch Error/Bug

2553
3
Jump to solution
05-20-2016 08:29 AM
BenGrod
Regular Contributor

In a Portal for ArcGIS Web App we randomly see the pop up for a map service not displaying as it is configured within the web map. We are in Portal for ArcGIS v1.2 and Web App Builder Developers Edition v1.3 Please see attached for a screen shot of the configured pop up and the incorrect display of the pop up. This is random and not specific to a map service or web map, it has occurred with different map services and different web maps. I'm guessing it is a bug and hoping other users have seen this occurrence.

0 Kudos
1 Solution

Accepted Solutions
BenGrod
Regular Contributor

It turns out that the Pop changes are not an error. A pop up can change size and configuration based on the size of the browser screen. For example if your browser fills the entire screen/monitor you will receive the complete pop up as configured in the web map. If you shrink the browser screen to very small you will receive a minimized version of the configured pop up, it will not even display the complete list of fields but just the first/title field. It's a design element by Esri rather than a bug.

View solution in original post

0 Kudos
3 Replies
BillFox
MVP Frequent Contributor

Hi Ben,

Take a look at this thread and see if it matches some of what you are seeing

With Portal for ArcGIS 10.3.1, has anyone else found that adding a layer to existing mxd and overwri...

-Bill

BenGrod
Regular Contributor

It turns out that the Pop changes are not an error. A pop up can change size and configuration based on the size of the browser screen. For example if your browser fills the entire screen/monitor you will receive the complete pop up as configured in the web map. If you shrink the browser screen to very small you will receive a minimized version of the configured pop up, it will not even display the complete list of fields but just the first/title field. It's a design element by Esri rather than a bug.

0 Kudos
LaurensGIS
New Contributor III

I do believe this is a bug. I have a webapp with language set to Dutch. This means that when you click on the map and there are two features, you will see "1 van 2" on the popup. When I make the browser screen smaller until the popup disappears, and I click on the same place in the map, the popup reopens in a different layout and it will say "1 of 2". 

So the layout of the popup changes and the language of the popup changes from Dutch to English.

0 Kudos