Portal for ArcGIS: Initial Administrator Account page not opening

7541
9
Jump to solution
02-25-2015 01:18 PM
JayantaPoddar
MVP Esteemed Contributor

Hey Guys,

I am trying to install Portal for ArcGIS (PFA) 10.3.4322.1 in my laptop [HP- ZBook; Intel Core i7, 2.70 GHz; 32 GB RAM; Windows 8 Pro, x64; WORKGROUP]. No proxy configuration.

I have successfully installed ArcGIS 10.3 Server and Web adaptor 10.3, and configured ArcGIS Server with Web Adaptor.

All the required ports have been allowed through firewall. And SSL has also been bound to port 443 with a self-signed certificate.

But, soon after the installation of PFA, the Portal for ArcGIS site (https://localhost:7443/arcgis/home) is invoked, but it ends up with "Unable to connect" page. Tried replacing localhost with the Computer name. The site is not opening even from the Windows start menu. I have tried both I.E. 10 and Firefox 36.

Therefore, I am not able to define the Initial Administrator Account.

What am I missing? Please guide.

Thanks,

Jay



Think Location
1 Solution

Accepted Solutions
JayantaPoddar
MVP Esteemed Contributor

Hi Eric,

The issue was finally solved. These are the following steps I followed to install the Portal for ArcGIS 10.3 in Windows 8 workgroup. I think the same goes with Windows 7 / 8.1.

1) Defined a Primary DNS suffix to the computer and restart the system.

     Control Panel > System > Computer Name, domain and workgroup settings. Click "Change Settings". On      "Computer Name" tab, click Change. Define the DNS suffix name for this computer.

2) Uninstalled Portal for ArcGIS from Control Panel and

     deleted "C:\Arcgisportal" and "C:\Program Files\ArcGIS\Portal" directories manually.

3) Ran "ccleaner" utility to get rid of the dirty files and registry issues.

4) Bound SSL Certificate to the website (Edit it, if already bound)

5) Installed Portal for ArcGIS. After the installation was finished, I was greeted with the Initial Administrator Account page.

Relieved!!!



Think Location

View solution in original post

9 Replies
TonyGegner
New Contributor III

Double check that your portal license is valid.

0 Kudos
JayantaPoddar
MVP Esteemed Contributor

Hi Tony,

the license is valid and working on a Windows 2008 R2 Server.



Think Location
0 Kudos
EricMcPhee
New Contributor III

I am currently struggling with the same problem...did you ever resolve this?

0 Kudos
JayantaPoddar
MVP Esteemed Contributor

Hi Eric,

I had to install Windows Server 2008 R2. Created a domain. And Portal for ArcGIS worked on it. Windows 7/8 machine can be used to work as a client.



Think Location
0 Kudos
JayantaPoddar
MVP Esteemed Contributor

Hi Eric,

The issue was finally solved. These are the following steps I followed to install the Portal for ArcGIS 10.3 in Windows 8 workgroup. I think the same goes with Windows 7 / 8.1.

1) Defined a Primary DNS suffix to the computer and restart the system.

     Control Panel > System > Computer Name, domain and workgroup settings. Click "Change Settings". On      "Computer Name" tab, click Change. Define the DNS suffix name for this computer.

2) Uninstalled Portal for ArcGIS from Control Panel and

     deleted "C:\Arcgisportal" and "C:\Program Files\ArcGIS\Portal" directories manually.

3) Ran "ccleaner" utility to get rid of the dirty files and registry issues.

4) Bound SSL Certificate to the website (Edit it, if already bound)

5) Installed Portal for ArcGIS. After the installation was finished, I was greeted with the Initial Administrator Account page.

Relieved!!!



Think Location
deleted-user-PgSJErWNjFC7
New Contributor

I have the same problem, but this solution hasn't worked for me.  After install, the browser jumps to http://example.com:7080/arcgis/home and for a split second displays the portal page, then goes to https://example.com:7443/arcgis/createadmin and fails to find a page. Sometimes I get a 440, sometimes I get a timed out error. 

SSL is installed (CA certificate), and I get the IIS default image at https://example.com:7443

I'm assuming it's somehow related to ssl, but maybe not?

Ports are open via the firewall.

Any ideas? 

I also feel like maybe I'm missing a page or two in the install process... for example, I don't really get any options before the install finishes. After umpteen reinstalls, the same thing has started happening to me on installing the web adaptor (it doesn't ask for the ports anymore). 

0 Kudos
JayantaPoddar
MVP Esteemed Contributor

Hi Raymond,

I haven't had the opportunity to used CA-certificate in SSL-binding.

Have you allowed the ports through firewall? Check method-2 in the following link.

How to Open Ports: 13 Steps (with Pictures) - wikiHow

Here are the list of ports for Portal for ArcGIS

Ports used by Portal for ArcGIS



Think Location
0 Kudos
deleted-user-PgSJErWNjFC7
New Contributor

All the ports were open (and I tried fully disabling the firewall briefly to test). Right now it appears I have solved the problem, but I'm not 100% sure which step fixed it. I removed all again and reinstalled a couple of times and eventually it worked. I think the key was that I deleted the bindings on the IIS server after clearing out all the other junk. 

0 Kudos
JayantaPoddar
MVP Esteemed Contributor

Hi Raymond,

Glad your issue is resolved. The main issue is caused by the dirty files/registries, which have to be cleaned first, and then binding the SSL again.



Think Location