How do we get the "Enable Attachments" button to show up on our portal feature layer?

1172
3
Jump to solution
08-14-2019 08:38 AM
JacksonTrappett
Occasional Contributor II

We are publishing a feature service to Portal (10.7.1) from Pro (2.4) for use with collector, and we'd like to enable feature attachments so that a photo can be taken in the field.  We have enabled attachments in the enterprise geodatabase, and they are working in Pro (we can add an attachment just fine via pro).  When we publish to a feature service, however, the feature service is missing the button "Enable attachments".

It's a little frustrating as all of the ESRI help just says "click the Enable attachments button" but doesn't say what to do if there isn't an enable attachments button.

What ESRI wants me to do:

ESRI instructions

What I see:

What I see

Any ideas?

Thank you!

0 Kudos
1 Solution

Accepted Solutions
jill_es
Esri Contributor

The documentation is referring to a hosted feature layer, meaning the data is copied to the ArcGIS Data Store.  Because you're using a feature service that references the registered enterprise geodatabase, this option isn't available within the ArcGIS Enterprise portal because available because the administration needs to take place within the RDBMS itself.

With this in mind, attachments enabled on the feature class will be respected in the feature service - so you should be good to go with your workflow in Collector.

View solution in original post

3 Replies
jill_es
Esri Contributor

The documentation is referring to a hosted feature layer, meaning the data is copied to the ArcGIS Data Store.  Because you're using a feature service that references the registered enterprise geodatabase, this option isn't available within the ArcGIS Enterprise portal because available because the administration needs to take place within the RDBMS itself.

With this in mind, attachments enabled on the feature class will be respected in the feature service - so you should be good to go with your workflow in Collector.

View solution in original post

JacksonTrappett
Occasional Contributor II

You're correct - per your suggestion, we ignored that the button wasn't there, and set up the Collector map, and attachments were enabled auto-magically.  Thanks for the tip! (we didn't see them until we re-created the collector map once attachments were enabled in the geodatabase.)

0 Kudos
jill_es
Esri Contributor

Excellent - glad to hear everything is working, Jackson! 

0 Kudos