Exporting map to graphics format --> Weird spikes in hatched polygons

2285
7
06-25-2012 03:05 AM
UweKurmutz
New Contributor
Hi guys,

I'm having problems with the export of a map which has hatched polygons in them. I'm not sure if this is the right forum, so if not, please show me in the right direction.

The problem: I'm having hatched polygons (45°) in my map which seem normal in data and layout view. As soon as I export the map to a graphics format (tried tiff and svg so far) weird spikes appear on them (see attached file). I tried different angles and it only disappears with completely horizontal or vertical lines. I also tried different sizes of stripes with different offsets, with the same result. The symbol itself always consists of a underlaying 'simple fill symbol' and on overlaying 'line fill symbol'.

Does any of you had similar problems or can offer a solution? Help would be very much appreciated.

Thank you, Uwe
Tags (2)
0 Kudos
7 Replies
JohnSobetzer
Frequent Contributor
This isn't an answer, just a possible workaround.  Change your simple lines to cartographic and see if that works; and if not do the same for the fill as well.  Simple are fast but sometimes in complex situations they don't display right.
0 Kudos
UweKurmutz
New Contributor
Thanks for replying. The line symbol is already 'cartographic'. Changed the underlaying solid fill to line fill too (also cartographic). The result improved a little, but it's still not usable for hq-printing. See attached picture: 1 - like I just described: two line fills with now smaller spikes; 2 - unaltered original ESRI fill with big spikes; 3 - my previous version with line fill on solid fill, also big spikes.  Spike sizes changes with line width and there's also a horizontal pattern in it, but I have no clue, where it's coming from. Anyone else?

Thanks, Uwe...
0 Kudos
LauraCoppola
New Contributor II
Is there a reason you can't export the map to a .pdf and print it from there? It looks to me like your problem is artifacts from the transition from vector (arc) to raster (.tff I know, and I think .svg as well).    Another thing I'd try is upping the resolution of your output image.  It'll make the file bigger, but should help some with the raggedness.
0 Kudos
UweKurmutz
New Contributor
Just tried it with pdf, but it still got all the spikes. Resolution is 300 dpi and with a format of A0+ the file is already 60 MB (lzw packed). Plus I need to have it as normal graphics format. Thanks though for your suggestions.
0 Kudos
JohnSobetzer
Frequent Contributor
The offset may be the cause of drawing errors.  If you can make an acceptable symbol without it you might try that.  If not you might try representations.  You might look at http://blogs.esri.com/esri/arcgis/2008/02/22/a-quick-clean-method-for-insetting-polygon-outlines/
0 Kudos
UweKurmutz
New Contributor
Ok, I played a little bit. Here's what I found out: The line offset doesn't change a thing. Simple Line Fill produces smaller spikes than Cartographic Line Fill. Turn off transparency and all spikes are gone. Turn transparency on and they're back. What to make of that? I need transparency for this complex map. Any ideas?
0 Kudos
JohnSobetzer
Frequent Contributor
If you have to have transparency, and you've played around with the resolution and the quality settings, about all I can offer is: 1. export to pdf and see if for some reason that produces a map without the spikes, and then convert it to a raster in Adobe Acrobat; or 2. export without transparency to Adobe Illustrator format and in Illustrator (maybe the free Inkscape) apply the transparency and see if it can save to a graphics file with better results.  Maybe others have better suggestions.
0 Kudos