Connection with ArcGIS Portal using Javascript API

918
1
Jump to solution
08-07-2017 09:01 AM
MalikAyaz
New Contributor II

Hello all,

I am trying to integrate my web map in application, using ArcGIS javascript API (4.4) using the code : 

esriConfig.portalUrl = "http://<PORTAL_URL>/portal"
var webmap = new WebMap({
portalItem: {
id: "XXXXXXXXXXXXXXXXXXXX"
}
});

I have a problem of slower performance, the first connexion between my browser and Portal Server is taking systematically 15-30 seconds to respond.

Normally the first HTTP request is 

https://<PORTAL_URL>/accessportal/sharing/rest/portals/self?f=json&culture=fr-fr

This creates application performance issue. Do you have any idea why this is behaving in this way. 

Thanks for your reply

Regards

Malik Ayaz

0 Kudos
1 Solution

Accepted Solutions
MalikAyaz
New Contributor II

My apologies for not replying earlier. I resolved this problem. The problem was not with platform ArcGIS but with HTTPS certificat. My certificat was auto signed. So because of this insecure connection, the first connection was very long. 

So I resolved the certificate issue and then the problem was solved. 

Regards

Malik

View solution in original post

1 Reply
MalikAyaz
New Contributor II

My apologies for not replying earlier. I resolved this problem. The problem was not with platform ArcGIS but with HTTPS certificat. My certificat was auto signed. So because of this insecure connection, the first connection was very long. 

So I resolved the certificate issue and then the problem was solved. 

Regards

Malik