Attribute Editing in Portal

3743
4
Jump to solution
02-20-2015 07:04 AM
BrendanDwyer
Occasional Contributor

We have an editable feature service in portal.  Some fields in the feature class have domains associated with them.  When a user edits a record in the attribute editor popup all the fields with domains have a warning message stating "This value is required."  Even though all these fields allow null values.  It confuses the users, because a) they know values in the fields are not required, and b) you can save the record with no error w/o putting a value in those fields.  What gives?  How can I suppress that warning?

0 Kudos
1 Solution

Accepted Solutions
JakeSkinner
Esri Esteemed Contributor

Hi Brendan,

An bug has been logged for this.  The bug states ArcGIS Online, but should apply to Portal once it's resolved.

#NIM098093 When a feature service using a domain with coded values in one of the fields is edited in ArcGIS Online, the warning saying "This value is required" should be removed, as it is not required

View solution in original post

0 Kudos
4 Replies
JakeSkinner
Esri Esteemed Contributor

Hi Brendan,

An bug has been logged for this.  The bug states ArcGIS Online, but should apply to Portal once it's resolved.

#NIM098093 When a feature service using a domain with coded values in one of the fields is edited in ArcGIS Online, the warning saying "This value is required" should be removed, as it is not required

0 Kudos
BrendanDwyer
Occasional Contributor

Jake,

Thanks for the info and the quick response.

-Brendan

0 Kudos
BrendanDwyer
Occasional Contributor

btw Is the bug fixed in 10.3?  We're migrating to 10.3 in the next few months.

0 Kudos
JakeSkinner
Esri Esteemed Contributor

It doesn't appear to be.  The great thing about Portal for ArcGIS 10.3 is the option 'Check for updates'.  Whenever updates are made to Portal, you can check by running 'Check for Updates'.  Ex:

screen1.png