collector offline areas

1209
6
Jump to solution
01-14-2020 12:56 PM
ColinPowers1
New Contributor II

Colin Lawrence

Hi Colin or anyone else, I had a quick question that I was hoping you could help me with. I am struggling to get an offline area downloaded on Collector. When I look at the troubleshooting logs I don't see any errors. Is there a place online where the errors are listed or where the verbiage for errors are listed so that I can look at to compare with my log? 

Every entry or listing in the log begins with [DOWNLOAD] and a number and I do not see the word "Error" anywhere. If there is an error will it say "ERROR"? or how would I be able to find the issue?

thanks,

Colin

0 Kudos
1 Solution

Accepted Solutions
ColinPowers1
New Contributor II

I was able to figure out the issue, it was a connectivity issue with my WiFi and within the logs there were some mentioning timing out and connectivity issues. Before I was not able to download offline maps of any substantial size on my local WiFi and when I switched to a hotspot the areas were able to download with ease. I appreciate the help and being directed to the developer/log option within the Collector app from some of your responses to other people's questions on the forum. Thanks!

View solution in original post

6 Replies
ColinLawrence
Esri Regular Contributor

Hi Colin,

What is the behavior you are seeing and is this unique to a single map/offline area? For example, can you explain what happens after you tap download (if anything)? If you have a screenshot of what you do see in the troubleshooting logs I can take a look and perhaps provide clarity.

Regards,

Colin

ColinPowers1
New Contributor II

I have created offline areas for a single map and when they exceed ~150mb in size they will not download. They sometimes hang at a certain size and then the app window closes and when I click on it to open it, it shows the offline area has not downloaded and the arrow button to download is available. Other times it gets to the last mb and then just resets itself and shows that it has not downloaded and is available to try again with the arrow button available.

I downloaded the troubleshooting log so I was able to ctr+f within it to look for the word Error and found these lines below..I tried to clean up the log a bit and removed the token section and url's, and I hope these are the relevant parts. 

1/17/20, 10:05 AM [5f0153d57f784c4faa4d558f98012567] - Layer: All_Permit_Poly2020 - Error: Error Domain=NSCocoaErrorDomain Code=206 "partial content" UserInfo={NSURL=https://ago-item-storage.s3.us-east-1.amazonaws.com/c4eead4ae8d64c81b2e96a0db9241e64/replica_357ea7f9b6e042709d97678a203be621.geodatabase?X-Amz-Security-

1/17/20, 10:05 AM [5f0153d57f784c4faa4d558f98012567] - Layer: _2019_RecSite_Data - Error: Error Domain=com.esri.arcgis.runtime.services.error Code=403 "Request Forbidden" UserInfo={NSURL=https://ago-item-storage.s3.us-

NSLocalizedDescription=Request Forbidden}

1/17/20, 10:05 AM [5f0153d57f784c4faa4d558f98012567] - Layer: GoAK Marine Debris Sites - Error: Error Domain=NSCocoaErrorDomain Code=206 "partial content" UserInfo={NSURL=https://ago-item-storage.s3.us-east-1.amazonaws.com/7e1eb3e7d549459299cd8f10e7ded248/replica_3deca6eb3f9e45b198da1db660747cda.geodatabase?X-Amz-Security-

Signature=89e4dae9e8012dfa74f51caa7624557a9c39568e3b4c8e5dd1b5a077a1d1d8f8, NSLocalizedDescription=partial content}


1/17/20, 10:05 AM [5f0153d57f784c4faa4d558f98012567] - Layer: _2018_RecSite_Data - Error: Error Domain=NSCocoaErrorDomain Code=206 "partial content" UserInfo={NSURL=https://ago-item-storage.s3.us-east-1.amazonaws.com/b1705457f63847538b0f27ccd613665a/replica_4b5e0c8bb6a2488e9989b744672d0594.geodatabase?X-Amz-Security-


1/17/20, 10:05 AM [5f0153d57f784c4faa4d558f98012567] - Layer: Analysis_Areas - Error: Error Domain=NSCocoaErrorDomain Code=206 "partial content" UserInfo={NSURL=https://ago-item-storage.s3.us-east-1.amazonaws.com/e30d4fc2055d443a9e2b0ab9469889de/replica_0cb32e6dc31d45ce9abe80335189088f.geodatabase?X-Amz-Security-


1/17/20, 10:05 AM [5f0153d57f784c4faa4d558f98012567] - Has errors but no error returned - layerErrors: [<AGSFeatureLayer: 0x2827b8e00>: Error Domain=NSCocoaErrorDomain Code=206 "partial content"

 NSLocalizedDescription=partial content}, <AGSFeatureLayer: 0x2827b8fc0>: Error Domain=NSCocoaErrorDomain Code=206 "partial content" UserInfo={NSURL=https://ago-item-storage.s3.us-east-1.amazonaws.com/c4eead4ae8d64c81b2e96a0db9241e64/replica_357ea7f9b6e042709d97678a203be621.geodatabase?X-Amz-Security-

0 Kudos
JohnPlunkett
Esri Contributor

What basemap are you using to create the offline area?

What is the coordinate system?

Are you able to share the rest end point with us?

0 Kudos
ColinPowers1
New Contributor II

I am just using the standard World_Topo_Map basemap and it says it is Spatial Reference: 102100  (3857). How would I go about sharing the map with you? through a ESRI group?

0 Kudos
ColinPowers1
New Contributor II

I was able to figure out the issue, it was a connectivity issue with my WiFi and within the logs there were some mentioning timing out and connectivity issues. Before I was not able to download offline maps of any substantial size on my local WiFi and when I switched to a hotspot the areas were able to download with ease. I appreciate the help and being directed to the developer/log option within the Collector app from some of your responses to other people's questions on the forum. Thanks!

ThomasColson
MVP Frequent Contributor

For the majority of us with poor (or no) connectivity issues, don't forget https://community.esri.com/ideas/10214 

0 Kudos