Collector for ArcGIS v18.1.0 (iOS) Released!

2136
32
12-04-2018 08:55 PM
Esri Regular Contributor
4 32 2,136

On Tuesday December 4th, 2018, we released Collector for ArcGIS v18.1.0 on the App Store. This is a significant evolution for Collector and field data collection workflows with the ArcGIS Platform. Please read details about the release here and provide your comments/feedback on the release:

Collector for ArcGIS (iOS) v18.1.0 Released! 

Collector Team

Tags (2)
32 Comments
New Contributor II

The Collector for ArcGIS v18.1.0 release looks great. Good job. With 3D modeling in ArcPro and AGO ArcScene becoming more popular and widely used, are you guys planning on integrating a way to edit these 3D models in Collector or developing a similar kind of mobile field app to do so? 

Thanks!

Zach

New Contributor III

Hi all.

 

Would I be correct in saying the new collector no longer supports the functionality of tracking my field based workers.

 

Many thanks

Occasional Contributor III

Yes, tracking is due to be taken care of by its own app in the future. Looks like you might be able to get in to a beta - Location Tracking Debuted at Esri User Conference (July 2018) 

by Esri Regular Contributor
Esri Regular Contributor

Yes, you are correct that workers aren't tracked directly in Collector. You can also see FAQ—Collector for ArcGIS | ArcGIS which has details on this.

New Contributor

Hi

I would like to know when the same release for Android is planed. Is there a date? There is some functionnalities that will change my way of planning my tables if I can use this new version really soon.

Thanks

Marie-Eve

New Contributor III

The new collector for IOS seems to be missing the Filter Related Types setting.

Without this we lose enforcement of the related records association of added records; a very important feature.

Classic Has: Settings --> Collection Settings --> Filter Related Types --> on/off

#Related##collector

Occasional Contributor III

Does this version of Collector support the Bad Elf GPS Pro?

I've tested Collector with my Bad Elf GPS Pro, and it can not connect to the device in a map, even though the iPad is connected via Bluetooth, and the connection has been established in the Collector settings. When I test this in Classic, I am able to locate myself immediately.

I ran the same test with a second GPS device - this time a Bad Elf GPS Pro+, and was able to successfully establish a connection in both Collector, and Classic with no issues.

Occasional Contributor II

Hi Erica,

Thank you for the feedback.

This is a known issue with the Bad Elf GPS Pro and the Lightning Connector devices in the current release of Collector for ArcGIS 18.1.0. However we have addressed this issue on our end to support these devices. This fix will be available in an upcoming release.

Thank you

-Kevin

Occasional Contributor III

Hi Kevin,

Is there an ETA for when this fixed release will be available to the public? I have some users interested in trying out the updated Collector in the field, who also use the Bad Elf GPS Pro. I'll save them the frustration of trying and failing for now, but would love if I could give them an ETA on a fix for this so they can use their GPS successfully.

Thanks!

Erica

Occasional Contributor II

Hi Erica,

Thank you for the response. This release is being targeted for mid-quarter 1.

Thanks

-Kevin

Occasional Contributor III

I'm curious about credential storage when taking Collector v18.1.0 offline. Does this function in the same way as with Classic? Specifically, does the same workflow need to be carefully followed that is described here?

FAQ: Is it possible to keep a Collector for ArcGIS account logged in without a connection for an ext... 

Occasional Contributor II

I am also curious about this.

New Contributor

I really like the new look, speed, feel.  Few questions: 

Are there any known issues with related tables?  I have several maps setup with related tables and they all seem to work except one.  The only difference I see is this map has two feature classes related to one object table.  So both features can populate an inspection to this table.  The relationships show up fine in AGO and Classic collector.  In new Collector it shows nothing when clicking related table link. It also will not let me add new...popup says "unable to create feature"  Any ideas?

Thanks 

Chad

New Contributor III

What is the ETA on the Android version of new Collector?

Esri Regular Contributor

Marshall, The Android version of the new Collector is in beta. You should be able to download it from the google play store. Support for the beta is channeled through the Early Adopter Community

New Contributor III

I'm having an issue with related records which I posted about here. I'm afraid I haven't received a responses about this yet. It sounds familiar though, basically coming down to Collector not saving/creating new related records. It's a bummer because I also like the new look and feel.

Esri Regular Contributor

Emily, how are your relationship classes set up between the parent and child features?

New Contributor III

The parent class is SESCLocations and the related table is SESCInspection. My supervisor set them up with SESCLocations having a 1 - M composite relationship with SESCInspection. I can ask him if there's another aspect of the relationship you need to know about. 

Esri Regular Contributor

What fields in each feature class are being used? Collector works best with a GlobalID-GUID relationship class since Collector can maintain that setup inside the app. 

New Contributor III

They have GlobalID fields, and SESCInspections (the related table) has a Rel_GlobalID field. This setup works fine in the classic Collector app. It's just the new Collector where we're having issues with saving new related records. The iPads we're using are 6th generation running iOS 12.1.1 and using Verizon, if that helps.

Going off on a bit of a tangent, it's possible this requires a support call, but I've only done Tech Support calls with issues on a desktop browser. Would you be able to tell me if/how Tech Support handles calls involving iPads?

Esri Regular Contributor

Emily, there are options where you can share your iPad through the screenshare software Tech Support uses. We also have iOS devices on hand in case screenshares don't work out - 

iOS Screen Sharing – Zoom Help Center 

They could ask for your data schema to see if it's reproducible on our end. I would also tell the analyst if you are using hosted feature services on Portal for ArcGIS or ArcGIS Online. If not, be ready to provide the ArcGIS Server version and database being used (SQL 2014, Oracle, 12c, etc). 

New Contributor III

Thanks, that should help in the future!

But for now, is there anything else you can tell me about issues with related records in the new Collector app? Chad's the first person I've seen posting about this, but then I realize this version is still relatively new. One difference I see is that Chad is getting an error message and I'm not. It also looks like he's using AGO and our webmap is built in Portal.

Esri Regular Contributor

Emily, not off the top of my head. I would test a new web map and test that only in Collector for ArcGIS (not Classic). 

New Contributor

Emily,

I created a support case and we did find a solution but never the cause.  I just downloaded the data.  Created a new empty feature class.  Loaded the old to new and republished.  It did the trick.  My related records show up and you can create new.  I'm not sure if our issues are the same but might not hurt to try this.  

New Contributor III

I'll speak with my supervisor and we'll give it a shot. It'd be great if it was something relatively simple like this. Thanks for the reply!

New Contributor III

I am having trouble explaining a Collector accuracy issue below. Can anyone help?

https://community.esri.com/thread/228178-collector-for-arcgis-accuracy-discrepancy

Occasional Contributor

I am having an issue with Offline Maps.  I have a relatively small area that is showing up in AGO under Manage Areas but in Collector for ArcGIS it says it is generating.  


Thanks,

Occasional Contributor

I am trying to use the FeatureSetBy to send information from a new GPS point to Survey123 from Collector. I am able to get this to work when I initiate Survey123 from within AGO but it does not work from Collector.  Will that be possible as it would be a great help when collecting new points where one wants to leverage other existing layers within a webmap.


Thanks,

New Contributor II

Hi Kevin,

I am curious if this fix has been released yet?  I have 10 iPad minis that are paired with a Bad Elf Pro that I will be distributing for the upcoming field season.  I would like to use the new Collector App but it is still not recognizing my Bad Elf Pro connection, although Collector Classic and Survey123 both recognize it. The new Collector app is updated on all the devices. 

I would appreciate any insight you may have about this.

Thank you!

Kaitlin Finan

US Forest Service

New Contributor III

Dan, hi - is Android still in Beta? One of my users has an Android device, how should I advise her to get the Beta version? I don't have Android so I cannot test for her. Does she need to sign up as early adopter and use TestFlight?

Esri Regular Contributor

Hi Katie,

Collector for ArcGIS (Aurora) on Android is still in beta:

https://www.esri.com/arcgis-blog/products/collector/field-mobility/collector-for-arcgis-beta-updates...

Testflight is iOS only.

by Esri Regular Contributor
Esri Regular Contributor

Hi Katie - Android is still in beta. You can have your user join our Collector Early Adopter community so she’ll have the latest information on what you can test as well as provide feedback. Once she has joined, she can access the latest beta release for Android by going to Getting Started.

About the Author
I am the Product Lead for our Field Apps team at Esri. I work with an amazing team building out our field solutions. Please feel free to ask me anything about ArcGIS Field Maps, Collector, Workforce, Explorer, Navigator, and Tracker.