Select to view content in your preferred language

connection to PostGresSQL db with Pro 3.2.2 only shows public schema

435
9
Jump to solution
04-30-2024 08:04 AM
Labels (3)
JasonFitzsimmons
Occasional Contributor

I am trying to connect to a PostgreSQL database that has a few schemas, including public. In Pro we can only see the public schema.

Using the same credentials in PGadmin, I can see all the schemas and all the tables and views in each one.

Something else missing?


 

 

0 Kudos
1 Solution

Accepted Solutions
George_Thompson
Esri Frequent Contributor

I wonder if there is an issue with the version of PostgreSQL you have. With Pro 3.2.x, the minimum supported version at v13.x is 12 (https://enterprise.arcgis.com/en/system-requirements/latest/windows/database-requirements-postgresql...). That could cause an issue.

I would update PostgreSQL to 13.12 (or newer) and then retest.

--- George T.

View solution in original post

0 Kudos
9 Replies
George_Thompson
Esri Frequent Contributor

What version of Pro and PostgreSQL are you using?

Does the user have "superuser" assigned?

What are the permissions of the user in question: https://pro.arcgis.com/en/pro-app/latest/help/data/geodatabases/manage-postgresql/privileges-postgre...

--- George T.
0 Kudos
JasonFitzsimmons
Occasional Contributor

Pro 3.2.2 
PostGreSQL 13.4
Its a read only account, we have admin too, but the use case only needs to view the data and not edit (Data Viewer role) with the same account and same credentials, I can see all the schemas

0 Kudos
George_Thompson
Esri Frequent Contributor

I wonder if there is an issue with the version of PostgreSQL you have. With Pro 3.2.x, the minimum supported version at v13.x is 12 (https://enterprise.arcgis.com/en/system-requirements/latest/windows/database-requirements-postgresql...). That could cause an issue.

I would update PostgreSQL to 13.12 (or newer) and then retest.

--- George T.
0 Kudos
JasonFitzsimmons
Occasional Contributor

I am a little unclear about that list, I see 

  • PostgreSQL 12.16 (64 bit)
    • PostGIS 3.3 

as a minimum requirement?
but it's true that we haven't updated in a while.

0 Kudos
George_Thompson
Esri Frequent Contributor

Here are the min. versions for Pro 3.2.x:
George_Thompson_0-1714502102805.png

Each major version of PostgreSQL (12, 13, 14, 15, etc..) are different from each other and have minor "updates" (.x) for each major version.

Herer is the link to the latest supported versions for windows: https://www.enterprisedb.com/downloads/postgres-postgresql-downloads

Hope that helps.

--- George T.
MarceloMarques
Esri Regular Contributor

@JasonFitzsimmons -

How to Upgrade the PostgreSQL and PostGIS version for the Enterprise Geodatabase on Windows
How to Upgrade the PostgreSQL and PostGIS version for the Enterprise Geodatabase on Linux
How to Move the PostgreSQL Enterprise Geodatabase with pg_dump and pg_restore


PostgreSQL Geodatabase Guide Books and Database Template scripts.

Mapping and Charting Solutions (MCS) Enterprise Da... - Esri Community

use the Production Mapping guidebook for PostgreSQL, the best practices can be used by any industry.

| Marcelo Marques | Principal Product Engineer | Esri |
| Cloud & Database Administrator | OCP - Oracle Certified Professional |
I work with Enterprise Geodatabases since 1997.
“ I do not fear computers. I fear the lack of them." Isaac Isimov
JasonFitzsimmons
Occasional Contributor

ok thanks!

0 Kudos
JasonFitzsimmons
Occasional Contributor

thanks!

0 Kudos
JasonFitzsimmons
Occasional Contributor

curiously, I only see the public schema when i connect using ArcGIS (stand alone) catalog 10.8.2 as well.

0 Kudos