Solution for BUG-000086319.

3419
17
06-08-2016 07:17 AM
LianaSmith
Occasional Contributor II

Does anyone have any solution for the bug (#BUG-000086319 Numeric field types within the attribute table in the Web AppBuilder still show the thousand comma that were removed in the webmap in arcgis online)?

In my query results numeric field values have commas that I do not need.

17 Replies
DanPatterson_Retired
MVP Esteemed Contributor

The most recent bug lists for arcmap are here http://downloads.esri.com/support/downloads/other_/1041-IssuesAddressedList.pdf for others, you will have to go to support and examine for previous versions and software.

0 Kudos
MelitaKennedy
Esri Notable Contributor

What version are you using? I'm seeing that it was verified as fixed in February but that might have been too late to make the March 2016 2.0 release.

LianaSmith
Occasional Contributor II

i have both 1.3 and 2.0. This problem occur in both..

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Liana,

  I have tested in WAB 2.0 and I am not seeing this issue anymore.

LianaSmith
Occasional Contributor II

Robert, I checked again and even created new application, but still get the same ( at the query results some values have commas). I noticed that commas appear only for the values whose format is long integer.

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Liana,

OK is this only happening with the query widgets results? If so then this is still an issue until the next release around UC time.

0 Kudos
LianaSmith
Occasional Contributor II

Robert, it only happens with the query widget results..I have seen that you were giving help to someone else with some changes that could be done in the code. By any chance do you have similar option for WAB 2.0? or 1.3? Thank you!

"There is no configuration in place for this. But you can easily add code to handle this. Open the Query Widget.js file and around line 1131 replace:"

  1.               fieldValue = this._tryLocaleNumber(fieldValue); 

with:

  1.               if(fieldAlias !== "Zip code"){ 
  2.                 fieldValue = this._tryLocaleNumber(fieldValue); 
  3.               } 
0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Liana,

  Are you now using the developer version?

0 Kudos
LianaSmith
Occasional Contributor II

Yes! I had to import it to Developer Edition to be able to change the code

0 Kudos