Required Fields in a Relevant Group

2458
8
11-02-2016 01:14 PM
GaryBowles1
Occasional Contributor III

I have a survey with 3 groups. All the questions in the groups are Required=yes. Each of the groups will only display depending on the answer to the first question of the survey (daily, weekly, monthly inspection). When i try to publish a completed survey, i receive an error that the required questions from the 2 non-relevant groups are required. I have attached a copy of the survey for review.

Thanks,

--gary

0 Kudos
8 Replies
JamesTedrick
Esri Esteemed Contributor

Hi Gary,

This is a known issue with Survey123 at this time.

0 Kudos
by Anonymous User
Not applicable

From my experience it helps putting the relevant expression for each question instead of only for the group. I tested it for your survey on a Samsung tablet and it worked. 

0 Kudos
IsmaelChivite
Esri Notable Contributor

Hi Gary Bowles‌, please check the latest update to the Survey123 field app. The issue should now be addressed with version 1.10. You can check what is new in this release at https://community.esri.com/groups/survey123/blog/2016/12/20/international-human-solidarity-day-relea... 

0 Kudos
Jean-YvesLandry1
Occasional Contributor

I'm using version 3.0.127 and I'm still having this error, required questions within a group that is not relevant are being flagged

0 Kudos
JamesTedrick
Esri Esteemed Contributor

Hi Jean-Yves,

Given the time difference between the initial post and your comment, it's likely that a different issue is causing a the same or similar effect.  Can you provide a copy of the XLSform?

0 Kudos
Jean-YvesLandry1
Occasional Contributor

Thanks James,

note that there are many null columns. 

0 Kudos
Jean-YvesLandry1
Occasional Contributor

Ok so I figured it out,  I thought I could save some time by having the relevance on a group containing the required questions, but it looks like you need a relevant logic on each required question in order for them to be validated.

0 Kudos
DamonPettitt
Occasional Contributor

I stumbled across this thread recently as i was having a similar problem trying to apply some logic to the "relevant" field of a "begin group" type where i had some required fields within the group. For me, i didn't need the fields to be required on my form, they were just set up to be required in the original feature service.

Anyway, in case this helps someone else, the way i achieved only having the "relevant" logic on the "begin group" was to put dummy fields inside the group (putting in "null" in the "bind::esri:fieldType" column for these fields since they weren't in my feature service) and then have my original, required fields outside this group with values in their respective "calculation" columns that referred back to the dummy fields.

So for example, inside the group you might have a field called HomeOwnerName_Initial. Then, outside the group, you would have a field called HomeOwnerName where in the "calculation" column it could say something like this: if(string-length(${HomeOwnerName_Initial})>0,${HomeOwnerName_Initial}, 'N/A'). Again, for me, i was just trying to deal with a situation where my original feature service fields required, but they didn't necessarily need to be required in the form itself.

0 Kudos