ERROR 000824: The tool is not licensed.

10760
13
01-28-2011 11:46 AM
HolmSeifert
New Contributor
Hi,

can anyone help me in resolving this error.
I have an arcgis 10 info education license.
I need the spatial analyst extension tools. All extension are enabled.


thanks
0 Kudos
13 Replies
Zeke
by
Regular Contributor III
You have to get/activate the license as well. Not sure about v. 10, but for 9.3x educational, there's a Desktop Administrator' icon under the ArcGIS folder under Start -> All Programs. Click that, then go through the steps to download (or activate) the license. Not sure offhand which of the options in Desktop Administrator you go through, but you can probably figure it out.
0 Kudos
HolmSeifert
New Contributor
Hi,

ok i have alle extension authorized, but the same error occurs.
0 Kudos
DanPatterson_Retired
MVP Esteemed Contributor
registering it gives you the license to drive...customize extensions, toggle SA gives you the keys (version access)
0 Kudos
SteveMiles
New Contributor
What about when using Model Builder?  I am trying to incorporate a custom extension into a model, but when I try to double click on the tool to change the inputs, I get the same error (a dialog pops up with "error 000824" saying the tool is not licensed).

Is there any way around this?
0 Kudos
BryanGunter
New Contributor
I am having the same issue with a custom geoprocessor that works fine in arcgis desktop 10 but gives "the tool is not licensed" error after being published to arcserver. 

The version of arcserver is enterprise advanced:

I tested the only custom geoprocessor example that i could find at ESRI's site to see if there were similiar issues: 

The example custom esri tool i tested is located at : http://help.arcgis.com/en/sdk/10.0/arcobjects_net/conceptualhelp/index.html#//0001000002r6000000

The above custom tool written by esri for example purposes gives the same error on my server when published as a service as my custom tool. 

So what is the deal with the tool not having a license anyone figure it out?

I have also tried the following code in the execute function to try to initialize the license for the previous examples.

public void execute (parameters,...,)
{
IAoInitialize pAoInitialize = new ESRI.ArcGIS.esriSystem.AoInitializeClass();
esriLicenseStatus licenstatus = pAoInitialize.Initialize(esriLicenseProductCode.esriLicenseProductCodeArcServer);

.........Calculations.....
........
pAoInitialize.Shutdown();
pAoInitialize = null;

}


thanks,
-Bryan
0 Kudos
sanjeevsinha
New Contributor II
Hi,

I am trying to create the schematic digram using the Geoprocessing Tool.
As per the esri sample i made a GP Model and published it as arcgis geoprocess service.

This model is running fine but giving the error "tool is not licensed" when running from the arcgis server web application.

I am using the 3 default gp tool in this model.

1. Make Layer
2. Select by location
3. Create diagram (Schematic tool)

I have also checked the license, All license are available. we have arcgis server advance and Schemati license for arcgis server.

Not able to figure out what is the issue...

Thanks for any kind of help.

sanjeev sinha
0 Kudos
jihadabdulhaq1
New Contributor
Go to GeoProcessing toolbar then geoprocessing options background processing uncheck "Enable" ..... click ok.
[ATTACH=CONFIG]14345[/ATTACH]
0 Kudos
JeffreySwain
Esri Regular Contributor
bjhunter -
When publishing to server you need to have the license for Server.  You have to have the Spatial Extension for server to provide that capability. The desktop license only applies when working in Desktop. 

sanjeeva -
For your publishing are you using a Windows Server?  I see that the Schematic Extension will only work on a Windows server per the above chart.  If that is the case,then I urge you to create a Support Incident to look into it further.
0 Kudos
Yohanes_BudiSulistioadi
New Contributor
Go to GeoProcessing toolbar then geoprocessing options background processing uncheck "Enable" ..... click ok.
[ATTACH=CONFIG]14345[/ATTACH]


For some reason I had the same error when executing very basic command, which was "clip". Following jihad.abdulhaq advise my computer just did the task. Thank you

PS:
ESRI Support Staff, any explanation on this?
I was running ArcGIS 10 licensed for ArcINFO in our school's network
0 Kudos