Why? Sync is checked, but layers are references in distributed collaboration

289
3
Jump to solution
02-29-2024 05:57 PM
AmyRoust
Occasional Contributor III

I have a two-way distributed collaboration between ArcGIS Online (host) and ArcGIS Enterprise Portal (version 11.1). I published a feature layer with data from an enterprise geodatabase to Enterprise Portal. I made sure to check "Enable Sync" in the feature layer properties before publishing. When I share the layer to the collaboration, it is always referenced instead of copied. WHY? 

0 Kudos
1 Solution

Accepted Solutions
AmyRoust
Occasional Contributor III

I finally found the issue! When publishing a service that you want to have copied instead of referenced in your collaboration, you must ensure that the following fields are visible in your table:

created_user

created_date

last_edited_user

last_edited_date

GlobalID

I was hiding some or all of those fields in every service I published. The annoying part is that if I made those visible and used the overwrite service option, it did not immediately switch to a reference. That wouldn't happen until the automated sync occurred (we have it set to go at midnight every night). 

I hope this saves people some headaches in the future.

View solution in original post

0 Kudos
3 Replies
TimoT
by
New Contributor III

Hi @AmyRoust,

There are additional steps required to share feature data sourced from an enterprise geodatabase across a distributed collaboration.

Check out the Esri documentation below:

Timo

0 Kudos
AmyRoust
Occasional Contributor III

Thanks, @TimoT! I'm in compliance with everything on that page. I've got a ticket in with Esri Tech Support now. We were on the phone for an hour and 15 minutes yesterday with no resolution. Fingers crossed that we figure something out!

0 Kudos
AmyRoust
Occasional Contributor III

I finally found the issue! When publishing a service that you want to have copied instead of referenced in your collaboration, you must ensure that the following fields are visible in your table:

created_user

created_date

last_edited_user

last_edited_date

GlobalID

I was hiding some or all of those fields in every service I published. The annoying part is that if I made those visible and used the overwrite service option, it did not immediately switch to a reference. That wouldn't happen until the automated sync occurred (we have it set to go at midnight every night). 

I hope this saves people some headaches in the future.

0 Kudos