Unable to Add Enterprise Portal in ArcGIS Pro

418
10
02-14-2024 10:07 AM
Labels (2)
CodyPatterson
Occasional Contributor III

Hey all,

I was curious if anyone has ran into the issue of adding the URL of your portal to ArcGIS Pro? I seem to be unable to add this as it continually presents an error.

CodyPatterson_0-1707933973849.png

 

This is through a reverse proxy, the actual URL on the browser works without issue, myself and others in the company are able to access it without issue. We changed the URL from a .local to a .com to adjust for a CA signed certificate, but when it was .local it worked just fine.

Anyone else experience similar?

Thanks in advance!

0 Kudos
10 Replies
Scott_Tansley
MVP Regular Contributor

Have you set the webcontexturl property?

At the point that you changed from .local to .com, did you have much content in there?  Please be aware that changing the name of the URL has significant consequences that are usually resolved by engaging Esri Professional Service to resolve them, it used to be an unsupported activity but I believe Esri have some tooling.

Scott Tansley
https://www.linkedin.com/in/scotttansley/
0 Kudos
CodyPatterson
Occasional Contributor III

Hey @Scott_Tansley 

The webcontexturl is indeed set properly from what I can tell. This new URL is a DNS alias of the older URL, but no content has been placed within the portal as of yet, so there should be no difference in server URL on pre-existing hosted services or items.

I'm aware of the consequences of changing this URL, as our portal was unfederated and refederated, the Server, Notebook, Datastore, and Workflow Manager all picked up the correct URL without an issue, but at this point it just seems to be the connection from Pro.

Cody

0 Kudos
Scott_Tansley
MVP Regular Contributor

Good to rule all of that out before we go further, thank you.

So when Pro connects to the portal, it's trying to see the federated "ArcGIS Server's" as well.

So you may connect to https://gis.portal.com/portal/home for example, but the servers (depending on your config) may be accessed as https://gisserver.local:6443/arcgis/ you will see what the 'background' URL is from the portal->organisation->settings tab and then then the 'servers' tab on the left hand side.  It will probably say something like:  

services url:  https://gis.portal.com/server

admin url: https://gisserver.local:6443/arcgis

If that's the case, then there is a possibility that firewalls or other network infrastructure may be blocking your Pro instance from communicating with the ArcGIS Server Admin APIs. 

It's difficult to know your specific settings because different people/organizations configure in different ways.

It's possible to use like Fiddler or Wireshark to sniff the traffic from Pro to understand what's happening.  That may be your best course of action.  

Typically, I build securely for my clients, so they get the same error as you if they try and publish from their laptop when home working.  If they VPN, then it generally works and it works when they're in the office as well.  So I'm thinking that may be the best place to review now.

Scott Tansley
https://www.linkedin.com/in/scotttansley/
0 Kudos
CodyPatterson
Occasional Contributor III

Hey @Scott_Tansley 

All URLs at this moment are identical, so both services and admin url are https://domain.com/webadaptor this was the recommendation by support following a supposed firewall issue, when in reality it was that no processes were listening. Once I showed them that once a process is listening with a Powershell script, they stated I could keep it that way. I sent off my Wireshark info to the technician but I doubt it'll be of any use to them, currently working with network technicians internally to see if they can find anything unusual as well. The servers are on the same network as our VM servers, so all accessible from within office at this point, but still without Pro.

Cody

0 Kudos
BillFox
MVP Frequent Contributor

If it is empty, maybe faster to burn it down and then up with the new values

Then you can verify the webcontexturl, admin url, privateportalurl, etc. are where you want them to be inside and out

0 Kudos
CodyPatterson
Occasional Contributor III

Hey @BillFox 

I appreciate the suggestion, but this is following a bottom up rebuild, this was the initial solution offered by ESRI support, but did not end up changing anything so far. It seems that the go-to would be to completely uninstall all servers and infrastructure due to ArcGIS Pro disconnecting.

Any other possible ideas?

Cody

0 Kudos
hlindemann
New Contributor III

Hi @CodyPatterson, in most of the cases that I have seen this is a configuration problem, my normal  process would be as follows:
check the ArcGIS URI's

https://e111.esri-southafrica.com/portal/arcgisuris.xml

if this does not align with your URL pro will not log in

hlindemann_0-1707975185560.png

if it is different then re-register your web adaptor this is usually the cause.

 

 

0 Kudos
CodyPatterson
Occasional Contributor III

Hey @hlindemann 

I had actually not thought about that, so thank you for the recommendation!

Sadly though, all links are identical:

CodyPatterson_0-1707999468927.png

I noticed both of ours had http and https intermixed, is that normal?

Cody

0 Kudos
HenryLindemann
Esri Contributor

Hi @CodyPatterson,Yes that is normal, there is an application called fiddler, you can install it and should be able to see what calls fail when connecting to ArcGIS Enterprise, I have had a case where I needed to re-install portal to get the pro login to work again, so I hope that is not the case here. 

I also had a case where the login URL went over 7443 for some reason, but fiddler should be able to confirm if this is the case.

Regards

Henry

0 Kudos