Web Appbuilder Widget Container Problem

188
6
Jump to solution
12-25-2018 07:46 AM
NadirHussain
Occasional Contributor

Dear All

Before my web app builder was working fine.from yesterday i am facing one problem.Before when i create custom widget i can see this widget in container.But from yesterday custom widget not visible in container tray.i try my best i uninstalled web app builder and then again install but i am facing same issue.Please help.

Thanks in Advance

0 Kudos
1 Solution

Accepted Solutions
NadirHussain
Occasional Contributor

Thanks Robert,

 it works know.

View solution in original post

0 Kudos
6 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor

Nadir,


  Most of the time when I see this, it is because you have an error in your widget you are developing and it causes the widget to not appear in the widget list. Do you see any errors in the browsers console.

0 Kudos
NadirHussain
Occasional Contributor

Dear Robert,

   Sorry for late reply.i was busy in some other tasks.i just copy demo sample from samples folder.and place outside of sample folder.i paste it in client--->stemapp--->widgets.i give the folder name listview.i changes the name in client--->stemapp--->widgets-->listview-->settings.i chenged the setting.js with this line

    baseClass: 'jimu-widget-listview-setting'.

i also changed base class in client--->stemapp--->widgets-->listview    widget.js

 base class line  baseClass: 'jimu-widget-listview'.

i also add the listview widget in client--->stemapp---->config.js

"widgets": [{
"label": "listview",
"uri": "widgets/listview/Widget"
}]
}.

After this i create new application in webApp builder.But i cant see listview widget in widget container.

what i am missing i could not understand.please help.

Thanks in advance.

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Nadir,

  Are there any errors in the browsers web console?

0 Kudos
NadirHussain
Occasional Contributor

Dear Robert,

i have not seen any errors in the browsers web console.

thanks for your reply

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Nadir,

   OK for future reference this step is not needed:

i also add the listview widget in client--->stemapp---->config.js

"widgets": [{
"label": "listview",
"uri": "widgets/listview/Widget"
}]
}.

If you do not see any errors in the console then the issue is that you are probably looking for the widget to be called listview in the widget choose dialog, but it is still going to be called Demo because the nls/strings.js file still has this (line 3):

define({
  root: ({
    _widgetLabel: "Demo",
    _featureAction_ShowVertex: "Show Vertex Count",
    label1: "I am a demo widget.",
    label2: "This is configurable."
  }),
NadirHussain
Occasional Contributor

Thanks Robert,

 it works know.

View solution in original post

0 Kudos