Create Widget Error

268
4
01-14-2021 08:29 AM
FrankGoehnerGoehner
New Contributor II

Hi,  we tried to implement the Change Map widget,  we developed it on WebApp Builder 2.17, and it worked perfectly.  When we tried to implement on ArcGIS Enterprise version10.7.1,  we get the error "Create Widget error"

FrankGoehnerGoehner_0-1610641738959.png

Does anyone have an idea on how to fix the error?

Thanks

0 Kudos
4 Replies
KenBuja
MVP Honored Contributor

Enterprise 10.7.1 uses WAB 2.12.

https://developers.arcgis.com/web-appbuilder/guide/about-versions.htm

You may have some components that aren't available in that older version.

FrankGoehnerGoehner
New Contributor II

Thanks Ken,  how do I download old versions of webapp builder,  I can't seem to find it.

 

0 Kudos
KenBuja
MVP Honored Contributor
0 Kudos
FrankGoehnerGoehner
New Contributor II

Hi Ken,

I just installed WebAppbuilder 2.12, and added in the new widget, and it worked in development.  But for some reason,  it still won't run in our 10.7.1 enterprise. I added a copy of the widget

0 Kudos