Attribute table Vs LayerList (open Attribute table)

849
7
Jump to solution
10-14-2016 04:39 AM
ItziarMartinez
New Contributor

Hi!

I have created a webmap with three featurelayers and select it from a new WAB app. I have added the Layerlist widget (with open attribute table option enabled) and keep the attribute table (AT) widget (it cames load by default)

What I do not understand is why if I opened my app and shown the attribute table from the left arrow, the two feature layers are shown with no option of close each tab ( I mean, with the "cross" symbol in the right corner of the tab) while

If I opened the layerlist and selected the "attribute table" option, it is added with the "cross symbol" option to close it.

Anyone can explain me why this difference?

Thanks!

Itziar

0 Kudos
1 Solution

Accepted Solutions
RobertScheitlin__GISP
MVP Esteemed Contributor

Itziar,

   The difference is a user opened table tab vs a AT widget configured table tab. You can configure the AT widget to display all, some or none of the layers in your web map by using the AT widget settings dialog. Layer that that configured in the settings dialog to show will not have a close button on them.

View solution in original post

7 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor

Itziar,

   The difference is a user opened table tab vs a AT widget configured table tab. You can configure the AT widget to display all, some or none of the layers in your web map by using the AT widget settings dialog. Layer that that configured in the settings dialog to show will not have a close button on them.

View solution in original post

ItziarMartinez
New Contributor

Hi Robert!

Understood. And.. what about the featurelayers that have been added to the map as a result or execute a query?I mean, I have created a new FeatureLayer from the featureset of the query result and add this to the map.addLayer(Mylayer) but again, there  is no cross in the AT Widget.

Is the same case?

Thanks!

Itziar

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Itziar,

   That's a sort of similar case. The tab will be removed from the AT widget only when the query is cleared.

0 Kudos
ItziarMartinez
New Contributor

What do you mean by "when the query is cleared"?, 

Is there any way to load the layer in the map and the result in the AT widget with the close buttom? (by code)

thanks!

Itziar

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Itziar,

   Sorry when I first read it I thought you were talking about the Query Widget. It may be in the way you are adding then to the AT Widget because with my eSearch widget the query results I am adding I get a close button on the tables tab.

0 Kudos
ItziarMartinez
New Contributor

I have been playing with this two widgets, and I realice that there are some layers that have problems with the AT, maybe the problem is with my layers but I am not sure.

When I open my app, the layer is show correctly, but when I open the AT there is an error in the firebug:

If I try to execute the last query:

http://10.81.6.16:6080/arcgis/rest/services/Limpieza_viaria_3/FeatureServer/0/query?f=json&returnGeo... 

It takes time, but it works.

If I have my custom widget (the one that i am working in) opened, this error makes my widget fails (I think that all the app start failing) Any idea where can I get more information about the error? Because I find that description of the firebug hard to get a start point to work in.

Thanks!

Itziar

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Itziar,

   I do not have an idea about this error.

0 Kudos