WAB 3D custom widget Add Shapefile works, but no pop-up

243
2
Jump to solution
09-07-2020 05:47 AM
MichaelLev
Occasional Contributor III

I created WAB 2.17 3D custom widget to add zipped shapefile. Its code is exactly as in sandbox of esri Javascript API 4.16 code example Create a FeatureLayer from a shapefile. It runs OK and I see the added shapefile both in the 3D scene and in "Layer List" widget.

My questions:

  1. If I run esri example or if I copy esri code example into an independent web app, then when I click on an added feature, a pop-up is opened, as expacted.
    But - In my WAB, I have a serious problem - When I click on an added feature, no pop-up is opened.
    I attach the relevant part from my Widget.js which is exactly as in esri example.
  2. I tried to manually define a feature layer popupTemplate, then I see it, but
    1. I have not succeeded to immitate the esri default templatePopup - see my other question
    2. I don't understand why the default popup does not appear and the manual popup do appear.
  3. I don't understand the comment in line 171 in the example, since anyway with esri example, the popup is opened by click. Does the comment mean that this is the place if I want to write code that changes the pop-up template?

The above is a great "show stopper" problem for me.

Help will be greatly appreciated,

Michael

0 Kudos
1 Solution

Accepted Solutions
MichaelLev
Occasional Contributor III
0 Kudos
2 Replies
MichaelLev
Occasional Contributor III

Dear Robert Scheitlin, GISP‌,

no one has yet replied to this wuestion,

can you help, please?

Michael

0 Kudos
MichaelLev
Occasional Contributor III

Answered in my other question.

Michael

0 Kudos