Unwanted <br> tags added when customizing popup

137
1
Jump to solution
11-19-2019 06:25 AM
FranklinAlexander
Occasional Contributor II

I am trying to customize a popup using the local layer widget and for some reason there is a lot of extra space at the top. After investigating, I found that about 20 or so <br> tags are being placed (not by me) before any of the content and I want to know how to keep this from happening. 

popup html:

<div style="width:250px;">
<table style="width:100%;">
   <tbody>
     <tr>
        <td style="color:#a6a6a6"><b><i>Entrance Name:  </i></b></td>
        <td style="color:#333333">{NAME_ENT}</td>
      </tr>
      <tr>
        <td style="color:#a6a6a6"><b><i>Management Type:  </i></b></td>
        <td style="color:#333333">{TYPE_MGT}</td>
      </tr>
      <tr>
        <td style="color:#a6a6a6"><b><i>Entrance Type:  </i></b></td>
        <td style="color:#333333">{TYPE_ENT}</td>
      </tr>
      <tr>
        <td style="color:#a6a6a6"><b><i>Website:  </i></b></td>
        <td style="color:#333333"><a href="{WEBSITE}" target="_blank">Website</a></td>
      </tr>
      <tr>
        <td style="color:#a6a6a6"><b><i>Longitude:  </i></b></td>
        <td style="color:#333333">{LON_dd}</td>
      </tr>
      <tr>
        <td style="color:#a6a6a6"><b><i>Latitude:  </i></b></td>
        <td style="color:#333333">{LAT_dd}</td>
      </tr>  
    </tbody>
</table>

<a href="https://www.google.com/maps?saddr=  &amp;daddr={LAT_dd},{LON_dd}" target="_blank">Directions</a>
</div>

popup looks like this:

screenshot of popup

Here is the console:

console.screenshot

I have the popup configured exactly the same way in the web map and it looks fine...no extra space at the top.

Thanks for any ideas as to what is causing this. 

0 Kudos
1 Solution

Accepted Solutions
FranklinAlexander
Occasional Contributor II

I fixed it. I had to delete all of the <br> tags in the popup description in the config file. Not sure why they get inserted, seems to only happen when custom configuring popups in the local layer widget.

View solution in original post

0 Kudos
1 Reply
FranklinAlexander
Occasional Contributor II

I fixed it. I had to delete all of the <br> tags in the popup description in the config file. Not sure why they get inserted, seems to only happen when custom configuring popups in the local layer widget.

View solution in original post

0 Kudos