Mobile Layout configuration

1297
8
Jump to solution
02-06-2017 05:17 AM
deleted-user-CQZbjNeBXm49
Occasional Contributor III

Please how do you re-adjust the mobile layout in WAD dev tailored to small screen devices as mine is just all over the place.

I have tried disabling some widgets in the config.json but to no effect.

Thanks for help

Baba

Tags (1)
0 Kudos
1 Solution

Accepted Solutions
RobertScheitlin__GISP
MVP Esteemed Contributor

Baba,

   I don't really think that there is enough room to add additional onscreen widgets. When using mobile layout you should consider moving all your widgets to the themes controller instead.

View solution in original post

8 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor

Baba,

  Are you adjusting the "mobileLayout" portion of the apps main config.json? I have never seen such a messed up layout on a mobile device. Did you create or alter the theme code?

0 Kudos
deleted-user-CQZbjNeBXm49
Occasional Contributor III

Hi Robert,

Yes I altered theme initially at v1.2 via the CSS to suit my organization's. It was not in this messed shape earlier but has only gotten worse after upgrades, however, renders perfect on tablets.

HELP!!!! 

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Baba,

   There has been significant css and code changes since 1.2 when it comes to mobile layout. So your best bet is to create a new app and then make your orgs css changes again (based on the new css rules) or struggle with what you have currently trying to back out your changes until you can figure things out (not recommended). You will honestly spend less time trying to make your changes to a fresh app, then trying to figure out the changes.

deleted-user-CQZbjNeBXm49
Occasional Contributor III

Thank you Robert,

I guessed as much, I will gradually...

Baba

0 Kudos
deleted-user-CQZbjNeBXm49
Occasional Contributor III

Hi Robert,

I found out that the error in display were caused by me modifying the locations of the on screen widgets.

deleted-user-CQZbjNeBXm49
Occasional Contributor III

Hi Robert,

Hope you had a glamorous weekend?, I have been rebuilding my wab application from scratch to make the mobile layout come out better, however, whenever I modify the theme (especially adding a new widget onscreen placeholder) the layout loses its arrangement (see image), what do you think might be wrong?

 

Thanks for the assistance

Baba

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Baba,

   I don't really think that there is enough room to add additional onscreen widgets. When using mobile layout you should consider moving all your widgets to the themes controller instead.

View solution in original post

deleted-user-CQZbjNeBXm49
Occasional Contributor III

Hi Robert,

Thanks for reply, mobile was just an oversell anyways for internal users, so I will take not when producing geoapp for field workers only

Cheers

Baba

0 Kudos