R-ArcGIS Bridge (v1.0.1.229) -> R-Studio & R v3.5.0

568
2
04-26-2018 09:23 AM
RamaSivakumar
New Contributor

Looks like the current version of R-ArcGIS bridge (v1.0.1.229) is not compatible with latest release of R (3.5). I got an error when attempted to bind the R-ArcGIS library in R-Studio. No issues enabling R ArcGIS package in ArcGIS Pro (2.1). 

R-Studio R-ArcGIS bridge error

Installed older version of R (3.3.2) and configured R-Studio to use older version instead of default current version to resolve issue.

R-ArcGIS Bridge binding using R v3.3.2in  ArcGIS Pro 1

R-ArcGIS Bridge binding using R v3.3.2in  ArcGIS Pro 2

R-Studio Configure to use older version of R

R-ArcGIS Bridge binding using R v3.3.2in  R-Studio

2 Replies
ShaunWalbridge
Esri Regular Contributor

Hello Rama,

Thank you for the report. R has changed its internal package format with the R 3.5 release, and we're working to address this issue, but don't have a package out yet that resolves the problem. We've added this issue to GitHub to track the problem: R 3.5 support · Issue #22 · R-ArcGIS/r-bridge · GitHub 

Cheers,
Shaun

ShaunWalbridge
Esri Regular Contributor

The latest release of the arcgisbinding package (v230) contains support for R 3.5. You can download it either from the Options > Geoprocessing pane of Pro, or using the R bridge installation toolbox, by running the "Update R bindings" tool. Let us know if you have any other questions or issues.

Cheers,

Shaun