Cannot install arcgisbinding since updating to R 4.3

1123
5
Jump to solution
05-23-2023 11:54 AM
Labels (3)
Lydco
by
New Contributor III

I was using arcgisbinding before updating to R 4.3 and ArcGIS Pro 3.1, but since updating I cannot get it to re-install.

Running the Install R bindings tool from ArcPro gives this error:
Warning: unable to access index for repository https://r.esri.com/bin/windows/contrib/4.3:
cannot open URL 'https://r.esri.com/bin/windows/contrib/4.3/PACKAGES'
Warning message:
package 'arcgisbinding' is not available as a binary package for this version of R
A version of this package for your version of R might be available elsewhere,
see the ideas at
https://cran.r-project.org/doc/manuals/r-patched/R-admin.html#Installing-packages

And installing the arcgisbinding package from RStudio appears to work:
package ‘arcgisbinding’ successfully unpacked and MD5 sums checked

..but when trying to load the package generates an error, despite removing and reinstalling:
Error: package or namespace load failed for ‘arcgisbinding’:
package ‘arcgisbinding’ was installed before R 4.0.0: please re-install it

Checking the Options\Geoprocessing menu in ArcGIS Pro and trying to install from there also generates an error:
Warning: unable to access index for repository https://r.esri.com/bin/windows/contrib/4.3: cannot open URL 'https://r.esri.com/bin/windows/contrib/4.3/PACKAGES'

Is this package not supported for the latest version of R? Or am I missing something?

1 Solution

Accepted Solutions
Lydco
by
New Contributor III

I received assistance on the Github issue board and was told that reverting to R 4.2.x is necessary for now. There is not yet a compatible build for R 4.3.

View solution in original post

5 Replies
Lydco
by
New Contributor III

Update: on 5/23 an update was made and I was told on the R issue board to try again. Installation now goes smoothly, but I still get an error upon loading into R despite multiple installation attempts:

Error: package or namespace load failed for ‘arcgisbinding’:
 package ‘arcgisbinding’ was installed before R 4.0.0: please re-install it

 

0 Kudos
Lydco
by
New Contributor III

I uninstalled R 4.3 and went back to R 4.2.3 and arcgisbinding works fine. I'd appreciate if anyone could share a solution that works with R 4.3.

0 Kudos
g_mcgowan
New Contributor II

I am having the same issue.

 

0 Kudos
Lydco
by
New Contributor III

I received assistance on the Github issue board and was told that reverting to R 4.2.x is necessary for now. There is not yet a compatible build for R 4.3.

MarthaBass
Esri Contributor

Following up - there is now an R-ArcGIS Bridge build that supports R 4.3 (v306). Reinstalling arcgisbinding via ArcGIS Pro (Project > Options > Geoprocessing > R-ArcGIS Support > Check package for updates) or R should resolve the issue!

Tags (1)