Arcgisbinding package install error in R

1424
2
Jump to solution
01-08-2021 02:05 PM
Labels (2)
Barty
by
New Contributor II

Hi all,

I am unable to install the arcgisbinding package in R. I'm running x64 and have tried with multiple versions of R (3.6, 3.6.3, 4.0, and 4.0.2) using the following fix posted on other blogs

 

install.packages("arcgisbinding", repos="http://r-arcgis.github.io/r-bridge", type="win.binary")

 

and no matter which version I use I receive the following error: Warning in install.packages :
package ‘arcgisbinding’ is not available (as a binary package for R version XXX).

 

Any thoughts here? THanks!

1 Solution

Accepted Solutions
DanPatterson
MVP Esteemed Contributor

R Arcgisbinding :: Anaconda Cloud from the esri Anaconda site?


... sort of retired...

View solution in original post

2 Replies
DanPatterson
MVP Esteemed Contributor

R Arcgisbinding :: Anaconda Cloud from the esri Anaconda site?


... sort of retired...
OrhunAydin
Esri Contributor

Barty, 

Another way you can safely update your arcgisbinding version is using our setup tool in ArcGIS Pro.

Projects --> Options --> Geoprocessing --> R-ArcGIS Support Tab. There you can pick the version of R you want to use and click on the arrow that will either display "Update package from the internet" or "Install package from the internet" depending on whether you have a pre-existing version of arcgisbinding.

If you are updating, I recommend it now because we just released v244, please make sure you do not have any active R instances while making the update.

Orhun