The modified geometry must be a different geometry

178
2
09-07-2020 01:54 AM
robert_at_work
New Contributor III

Hi,

I get the following error message when I run my arcpy script:

Error: The modified geometry must be a different geometry instance from the feature's original geometry (e.g., a copy or new instance)

Our environment is:

- ArcMap 10.5.1. and Oracle 11gR2 (production - own oracle instance)

- ArcMap 10.7.1. and Oracle 11gR2 (test - own oracle instance)

The error message appears only if used against our test-database (no matter if run in ArcMap 10.5 or ArcMap 10.7). The test-database should be identical to our production database. When I wrote the script a few month back I did all the testing against the test-database. The script has been used since then only with the production database. In the meantime - some weeks ago - we updated our test-environment and installed ArcMap 10.7.1 and also updated the SDE and user data schemas accordingly. Last week I ran  the script against the test-environment and got the aformentioned error message. The features are the same in test and production. The issue cant be solved by using shape@ or shapexy as suggested here.

The script moves  point features or a single vertex of a polyline to a specific point location (target) in the selection set.

The script loops through the polyline to find the closest vertex to the point location (target).

Now it looks to me that - when run against the test-database - the point feature or the closest vertex of the polyline is identical with the point location (target). The only thing I can think of right now is some kind of snapping or tolerance but I havent found anything about that which fits to the situation I'm facing. The coordinate of the target point and the coordinate of the closest vertex (polyline) or pointfeature are more than 1m away - so not even very close.

Any ideas how to narrow down whats going on here?

Many thanks, Robert

logging output:

---- Production database (ArcMap 10.5. SDE)
OK - target: 2736527.82,1251708.598 auf Layer AV_EO_TW_PUNKT
\\...\ELE_EDITOR_GNSAXEP2.sde.
START 6789  Werkplan\Trasseeverlauf  --> FeatureId / layer
->row[0]]                            --> FeaturePart
Polylinie - Vertex
Part 0:                              --> looping through vertices
2736529.40702, 1251709.203           --> start
2736677.20701, 1251726.20199         --> end
Polylinie - Vertex - End



---- test database (ArcMap 10.7. SDE)
OK - target: 2736527.82,1251708.598 auf Layer AV_EO_TW_PUNKT
\\...\ELE.ELE_EDITOR.GNSAXET.sde.
START 6789  Werkplan\Trasseeverlauf  --> FeatureId / layer
->row[0]]                            --> FeaturePart
Polylinie - Vertex
Part 0:                              --> looping through vertices
2736527.82002, 1251708.59799         --> problem: start vertex is identical whith target !
2736677.20701, 1251726.20199         --> end 
Polylinie - Vertex - End‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍
Tags (1)
0 Kudos
2 Replies
JoshuaBixby
MVP Esteemed Contributor

Does this happen if the data is in a FGDB?  Knowing that would help isolate whether it is a client or server issue.  Once you know that, I would contact Esri since you have isolated the issue quite a bit, and it appears to be a version-related defect.

0 Kudos
robert_at_work
New Contributor III

Hi Joshua,

script runs through with Arcmap 10.7.1 and a FGDB. 

Don't have direct ESRI support and need to go through reseller - will see if they pass it on....

Regards, Rob

0 Kudos