python add-in combobox

593
4
01-15-2018 03:15 PM
SheilaChurchill1
New Contributor II

ArcMap Ver. 10.5, Python Ver. 2.7

Python Add-in ComboBox no longer working.

In versions 10.3 and 10.4 of ArcMap I  created multiple Python Add-ins, from the tutorial in the Help to my own custom Add-ins. I am trying to run the Add-ins I have created in previous versions using ArcMap 10.5 and ArcMap the GUI. In all of my Add-ins (which worked perfectly in 10.3 and 10.4) Tools and Buttons work fine, but when I attempt to use the ComboBox, ArcMap crashes and I get the error report window. When I start ArcMap again, the Add-in is still installed, but when I attempt to use the ComboBox again, nothing happens, and no errors appear in the Python window. This also happens in the Add-in example given in the Help Documentation (Creating a Python Add-In Combo Box—Help | ArcGIS Desktop ). I also created a brand new Add-in following instructions in the Help, and it crashes when I use the combobox as well. I cannot find this as a reported bug - has anyone else encountered this problem?

0 Kudos
4 Replies
DanPatterson_Retired
MVP Esteemed Contributor

You are right... combobox errors are for much older versions.

If your code isn't exactly as given in the help file, perhaps you can share it in case people that use add-ins can see a version specific change that isn't documented with a version warning.

0 Kudos
JoeBorgione
MVP Esteemed Contributor

I just started using Python addins earlier this fall (version 10.5.1), and have used a combobox a few times.  I've never had a crash with one and they seem to do what I want with them. My suggestion is to get ahold of tech support, but escalate it past the first contact.  The error you display indicates a dump file was created, and somebody somehwere on the ESRI food chain can analyyze it.  I can't remember exactly where dump files get saved, but it's under your user name and the ESRI/ARCGis profile directories. Search for .dmp extentsion.  Sending the dumpfile as indicated in the error window is laughable:  I like to think they just go to Jack D's junk email folder.....

That should just about do it....
0 Kudos
SheilaChurchill1
New Contributor II

Finally figured it out! We are working in a virtual environment, and it was the new version of Citrix Receiver that was causing the problem, not the ArcMap 10.5. So when we switched back to Citrix Receiver Ver. 4.7 , ArcMap 10.5 Python Addin ComboBox worked again! The version of Citrix Receiver that caused the problem was Ver. 4.10.

RebeccaStrauch__GISP
MVP Esteemed Contributor

Thanks for providing that info about Citrix and the python combobox.  We have other issues with newer versions of Citrix and ArcGIS, but I don't remember the exact issues and/or if it was Receiver or XenDesktop.  It's one of those things you don't think to check right away, but as we seem to be moving to the VM direction more, it is good to remember this.

Things are circling once again.... back to the old central computer and "dumb" terminals (although the new VM boxes aren't all that dumb).

0 Kudos