Inconsistent python enviroment

1460
3
05-04-2022 11:12 AM
IVIE
by
New Contributor

Hi everybody, 

I have upgraded my ArcGIS Pro version to 2.9 and ever since I'm not able to install any python packages in the cloned environment using conda. Whenever I'm trying to install something I get  a message saying The environment is inconsistent; please check the package plan carefully. The I get a list of inconsistent packages and the install is getting stuck in the Solving environment step. 

I have tried reinstalling Anaconda, but with no luck. It only happens for the cloned ArcGIS Pro environments. If I create an environment from scratch it doesn't happen.

Does any of you have an idea of what might cause this issue?

Thank you!

 

 

0 Kudos
3 Replies
HannesZiegler
Esri Contributor

Hi @IVIE,

Were the clone(s) created at 2.9, or are they from a prior version of Pro?

0 Kudos
IVIE
by
New Contributor

Hi Hannes, 

Thanks for your quick reply. 

I cloned the default environment from ArcGIS Pro 2.9. I'm not using the old environments anymore.

0 Kudos
HannesZiegler
Esri Contributor

It appears to me the default environment arcgispro-py3 is in a bad state. 

First please try this to confirm:

From Python Command Prompt, run the following:

conda create -n arcgispro-py3-test arcpy

proswap arcgispro-py3-test

conda install <x> <y> <z>

*<x> <y> <z> are placeholders for the packages you want to install, replace these with appropriate package name(s).

Are you still seeing the inconsistency warnings?

If so, could you try uninstalling Pro, then make sure that %programfiles%\ArcGIS\Pro\bin\Python\envs\arcgispro-py3 is completely removed before re-installing Pro? After this, it should be back in a good state.

0 Kudos