ERROR 000824: The tool is not licensed. Failed to execute (Near).

2209
3
Jump to solution
02-07-2018 07:19 AM
JustinBridwell
New Contributor II

I am running Esktop 10.5 and Python27. I have arcpy working fine from my IDE but 

when I try to run the following, I get an error:

myNear = arcpy.Near_analysis(school_layer,tri_layer,"5000 meters") 

The error says: 

ExecuteError: Failed to execute. Parameters are not valid.

ERROR 000824: The tool is not licensed.
Failed to execute (Near).

I tried looking this up in stack exchange, but the best that I could come up with is that 1) Either Near_analysis is part of some extension that requires an additional licnese/payment or 2) There is something incorrect about the parameters being used. Any ideas?

0 Kudos
1 Solution

Accepted Solutions
JakeSkinner
Esri Esteemed Contributor

Hi Justin,

The Near tool requires an ArcGIS Desktop Advanced license:

Near—Help | ArcGIS for Desktop 

You may only have an ArcGIS Desktop Standard license.  You can check by going to Help > About ArcMap.  You will see the License Type there.

View solution in original post

3 Replies
JakeSkinner
Esri Esteemed Contributor

Hi Justin,

The Near tool requires an ArcGIS Desktop Advanced license:

Near—Help | ArcGIS for Desktop 

You may only have an ArcGIS Desktop Standard license.  You can check by going to Help > About ArcMap.  You will see the License Type there.

JustinBridwell
New Contributor II

Yep. That's the issue. :(

0 Kudos
XanderBakker
Esri Esteemed Contributor

You may want to have a look at a post by Dan Patterson‌: /blogs/dan_patterson/2017/01/23/generate-near-table-for-points  using numpy.