Select to view content in your preferred language

Geoprocessing packages from ArcGIS Pro 3 fail to load/run in LocalServer 100.15

548
2
Jump to solution
02-28-2023 06:58 AM
Labels (2)
HeatherKyle
New Contributor II

I have two geoprocessing packages, exported/generated from ArcPro 3.0 with Runtime support enabled, that fail to load when I try to do so in my .NET 6 application. The error I get is the following:

Esri.ArcGISRuntime.Http.ArcGISWebException
HResult=0x00000000
Message=Failed to create service createrasterdataset GPServer. Worker process 'createrasterdataset_host' exited while attempting to service request (attempt 1 of 1): endpoint='admin' headers={} params={asynchronous=, filePath=c:\arcgis\createrasterdataset.gpkx, jobDir=c:\arcgis\ArcGISTemp\arcgisruntime_56612\createrasterdataset\jobs, maxRecords=800, name=createrasterdataset, outputDir=c:\arcgis\ArcGISTemp\arcgisruntime_56612\createrasterdataset, type=GPServer, virtualDir=http://localhost.:50000/zDXgjS/outputdir/createrasterdataset} res='create' post=0 Crash dump path=
Source=Esri.ArcGISRuntime
StackTrace:
at Esri.ArcGISRuntime.Http.ArcGISHttpClientHandler.ArcGISClientHandlerInternal.<SendAsync>d__15.MoveNext()
at System.Net.Http.HttpClient.<<SendAsync>g__Core|83_0>d.MoveNext()
at Esri.ArcGISRuntime.LocalServices.LocalService.<StartServiceInternal>d__25.MoveNext()

I have not been able to find any documentation to direct me as to what I am doing wrong. Any assistance would be greatly appreciated.

0 Kudos
1 Solution

Accepted Solutions
MichaelBranscomb
Esri Frequent Contributor

Hi

Unfortunately, packages created at version 3.0 are not yet supported (for the version matrix see System requirements for 200.0 | ArcGIS Maps SDK for .NET | ArcGIS Developers).

But, when using ArcGIS Pro 3.x and using the Package Result GP tool you should be able to uncheck All Versions and just check 2.9. For more info see Package Result (Data Management)—ArcGIS Pro | Documentation.

 

Thanks

View solution in original post

0 Kudos
2 Replies
MichaelBranscomb
Esri Frequent Contributor

Hi

Unfortunately, packages created at version 3.0 are not yet supported (for the version matrix see System requirements for 200.0 | ArcGIS Maps SDK for .NET | ArcGIS Developers).

But, when using ArcGIS Pro 3.x and using the Package Result GP tool you should be able to uncheck All Versions and just check 2.9. For more info see Package Result (Data Management)—ArcGIS Pro | Documentation.

 

Thanks

0 Kudos
HeatherKyle
New Contributor II

Thank you very much Michael, switching to version 2.9 has my exported packages loading successfully now. I appreciate the links to the correct documentation as well.