Operation Dashboard issue: "Layer Not Accessible"

2391
3
08-12-2019 01:36 PM
KatelynNiesen
New Contributor

Hi all,

I'm working on creating a dashboard with a layer that has points/locations derived from a csv. When attempting to load the layer into the dashboard, the layer (and others) are grayed out with a message "Layer Not Accessible". I have tried making the layer a hosted feature layer in Pro, although it still shows as accessible. Does anyone have an idea as to why this is happening? 

Further, would anyone mind explaining the criteria needed for a layer to sufficiently work in a dashboard? I have a feeling I may be missing a step. 

I appreciate any guidance, thank you!

Reply
0 Kudos
3 Replies
DerekLaw
Esri Esteemed Contributor

Hi Katelyn,

> I'm working on creating a dashboard with a layer that has points/locations derived from a csv.

Yes, you should make it a hosted feature layer in either ArcGIS Online or Portal for ArcGIS, so Ops Dashboard can work with it.

> When attempting to load the layer into the dashboard, the layer (and others) are grayed out with a message "Layer Not Accessible".

Have you ensured that the feature layer(s) have been shared correctly? Are you the owner of all the layers in the web map that you're trying to create a Dashboard for?

Hope this helps,

Reply
0 Kudos
ChristyCox2
New Contributor

This is also happening to me in Portal.  The layer that is giving me problems is a hosted feature layer that I posted to Portal. And I shared it correctly and am the current owner of all the layers in the web map that I am trying to create a Dashboard for. 

Thank you, 

Christy 

Reply
0 Kudos
DerekLaw
Esri Esteemed Contributor

Hi Christy,

To help collect more information to try and track down the cause, can you record the web traffic when you try to access the layer with something like Fiddler or Wireshark?

Reply
0 Kudos