Maplex Label Engine - Duplicate labels search radius not working in 10.5.1

2068
10
07-28-2017 01:13 PM
Highlighted
Occasional Contributor II

I just recently upgraded to ArcGIS 10.5.1 and I think I've found a bug.

It's happening on 2 machines here running 10.5.1 We haven't upgraded any others.

In the Placement Properties - Label Density tab of the Label Manager when using Maplex Label Engine if you check Remove Duplicates then click options and enter any number, press OK and get out of the manager then go back in, the number is now 0. Try to change it to another number and it reverts to 0 when you go back in.

Is anyone else experiencing this?

Michael Rivera

Southern Georgia Regional Commission

Valdosta, Georgia

10 Replies
Highlighted
Esri Contributor

Hi Michael,  


It looks like you may have found an issue. The Maplex team is currently investigating this. We'll get back to you as we have more information about it. 


Thanks for pointing this out to us,
David

Reply
0 Kudos
Highlighted
New Contributor

Any update on this issue?

Thanks,

Clarissa

Highlighted
Occasional Contributor II

I came across the same problem.

Highlighted
New Contributor

I noticed a similar problem with the 'Remove Duplicates' function. When I enter a number, it retains it but it makes no difference at all. I tried 0 and 100 and the duplicate labels do not get removed either way. Its just not working.

Any updates as to this problem?

Highlighted
New Contributor III

I also notice a similar problem with the "Remove Duplicates" function in ArcGIS 10.5.1 using Maplex labeling. When I enter or change the existing or default value, it does not retain the new value. Like for example, when I try to change the value from 0 to 1000 map units (meters), it does not change but retains the original value i.e. 0.

However, I can easily change 0 to 1000 or any other value in ArcGIS 10.3.1.

Any update to this problem??

Reply
0 Kudos
Highlighted
New Contributor II

Just updated to 10.6, but unfortunately this problem still exists.

Matthijs

Reply
0 Kudos
Highlighted
MVP Regular Contributor

Yes, utterly frustrating. This issue is not fixed in 10.6.

Highlighted
New Contributor II

We just upgraded to 10.5.1 and are experiencing this bug. Esri, when can we expect a patch?

Reply
0 Kudos
Highlighted
New Contributor III

This problem does not apply to Point and Line feature classes in ArcGIS 10.5.1. You can easily change the values in "Remove Duplicates" function using Maplex labeling.

However for Polygon feature class, ArcGIS 10.5.1 does not allow to change values. You can only Enable/Disabled "Remove Duplicate" function. By enabling Remove Duplicate function, ArcGIS will remove all duplicates and show only Single label in an opened map extent area. If you Pan the map extent, the label will shift to another place but will remain Single.

I hope this info will help us.

Reply
0 Kudos