Windows 10 Task Scheduler- Runs but nothing happens

1257
2
01-18-2021 12:18 PM
mmedinamilam152
New Contributor III

Alright, 

I am on my way to the home base. Now, hopefully the last question I will have to ask for a while. I have all my scripts working for my Citizen Problem Reporter. I even have it updating in the reverse. Took some real innovative thinking but Workforce updates and Citizen Manager Reporter both update each other whenever there is a change. 

 

Now, when I run my script manually the script takes about 45 seconds. When I set up the task scheduler it took 4 hours/ 2 hours to run even though I set one up to run every 20 minutes and the other to run every 5 minutes. Workforce assignment creator and service functions scripts respectively. 

I googled a solution. I exported it and changed the priority to 4 and reimported the task.  I am scared to change it below that. That didn't work. They are still running too long to run. 

I have windows 10 64 GB RAM  64 Bit Operating system with 64 based processor

I tend to run a little on the high side for my memory because of ArcPro but that hasn't been a problem so far when I do it manually. 

Any suggestions?  

 

0 Kudos
2 Replies
by Anonymous User
Not applicable

Check to see which version of python your script is running on. If you are like me I have several python installs on the system. you can also throw in this little code at the start to see which environment your script is executing in.

import sys
print "Running against: {}".format(sys.version)

 

mmedinamilam152
New Contributor III

I noticed that the script was working. The thing that wasn't working was the emails. It was because the direction of the script and the direction of the emails were in the same locaiton. I took the direction of the emails off and now the script runs and doesn't jam. 

0 Kudos