Union Warning 000117 doesn't even create an output feature class

1140
5
11-08-2017 03:33 PM
MarkJackson
Occasional Contributor

Union tool via ArcGIS Pro (2.0.1) GUI "Completes" with the following warning:

WARNING 000117: Warning empty output generated.

But no feature class is created in the project geodatabase. 

The Union geoprocessing tool ran for 3 hours and 44 minutes before telling me it "completed" with warnings when in fact it did absolutely nothing.

  • Sole user on a XenApp server with 4 Tesla P40 NVIDIA GRID cards
  • Same data, sole user on local Windows 10 with 32GB RAM, AMD R9 (5k iMac bootcamp)
  • CPU usage never went above 30% on either machine, and GPU performance hovered around 10% on the GRID cards and 17% on the AMD card. Memory went up to 8GB on both, sometimes lower.

The local machine "finished" a few minutes (3 hours 38 minutes) earlier with the same error.

I did a simple definition query on the two input layers to limit to a single state and ran the Union again with the exact same inputs and outputs. It completed in under a minute and produced a union of the inputs. 

So, is this an issue with the Union tool, or is it a limit on the data handling ability of ArcGIS Pro? 

If the latter, I'd really appreciate it if Esri would just add some code that honestly said "Nope - that's too much data for me. Cut it in pieces and try again." rather than pretending to do something for hours, then having the gaul to say that it "completed" the job you gave it with some warnings. 

Parent: Wow. You've been out there a long time. Did you finish the lawn?

Youth: Yeah, it took me a couple hours, but I completed it, with a warning.

Parent: A warning? What warning?

Youth: The lawnmower wouldn't start, so I just walked around the yard looking at the lawn for a couple hours before I decided the job was complete.

Parent: ?! 

0 Kudos
5 Replies
DanPatterson_Retired
MVP Esteemed Contributor

are both in the same coordinate system and are both coordinate systems known?

Union will project on the fly if the coordinates systems are known.

http://pro.arcgis.com/en/pro-app/tool-reference/appendices/spatial-reference-and-geoprocessing.htm. All the input feature classes are projected (on the fly) into this spatial reference.
0 Kudos
MarkJackson
Occasional Contributor

Yes - both are GCS WGS 1984 from the Esri Data and Maps for ArcGIS 2016 Census data. 

0 Kudos
DanPatterson_Retired
MVP Esteemed Contributor

Things to check/confirm from Union 

  • The inputs are featureclasses in a file geodatabase (failure can occur if they aren't see tiled-processing below)
  • Split policy is ignored.  
  • Are the shapes multipart or singlepart? (ie one table record highlights many shape versus a single shape)
  • if you do a physical selection (not a definition) in a small area, does it work? ( overlay tools are supposed to tile inputs if needed

Things to explore

0 Kudos
MarkJackson
Occasional Contributor

Things get worse. Using the same data, but this time saving the output to a geodatabase that is on a mapped network drive, the Union completes with no warnings or errors. Except that when it draws it stops after about 100 polygons (should have over 1 million). Trying to open the attribute table results in an error. The fields show up with no data while the error dialog is on the screen, but the table closes when you click OK. 

Clearly there is something wrong if the Union tool happily reports that it did it's job with no errors and the result has .01% of the geometry it is supposed to and 0% of the attribute data. 

Error!

0 Kudos
DanPatterson_Retired
MVP Esteemed Contributor

work local... mapped network drives add a new dimension... see other comments I posted

0 Kudos