Raster to Point Output: Points On Edge of Cells, Not Centered

2878
3
Jump to solution
12-12-2013 03:47 AM
JustinEddings
New Contributor III
Hello,

The Raster to Point tool embedded within my model  is outputting points on the edge of the raster cells rather then in the center, resulting in model outputs that are spotty.  I attempted running the conversion tool outside of the model and continue to get the same result.  I thought their might be something in the Environment Settings but can't figure out what it is.  Previously, the model ran seamlessly so I don't what has changed to make the tool function like this.  Thanks!

-Justin
0 Kudos
1 Solution

Accepted Solutions
JustinEddings
New Contributor III
After some further adjustments within the model Environment Settings, I switched the processing extent to Default rather than the extent of the area polygon that the rasters are clipped within.  This has centered the points on their raster rather then on the edge.

Hello,

The Raster to Point tool embedded within my model  is outputting points on the edge of the raster cells rather then in the center, resulting in model outputs that are spotty.  I attempted running the conversion tool outside of the model and continue to get the same result.  I thought their might be something in the Environment Settings but can't figure out what it is.  Previously, the model ran seamlessly so I don't what has changed to make the tool function like this.  Thanks!

-Justin

View solution in original post

0 Kudos
3 Replies
JustinEddings
New Contributor III
Rerunning the tool in a new blank map with the same raster, outputs the expected center point with value for each cell.  This should confirm that its an environment setting in my saved map.  I just don't know what.
-Justin
0 Kudos
JustinEddings
New Contributor III
After some further adjustments within the model Environment Settings, I switched the processing extent to Default rather than the extent of the area polygon that the rasters are clipped within.  This has centered the points on their raster rather then on the edge.

Hello,

The Raster to Point tool embedded within my model  is outputting points on the edge of the raster cells rather then in the center, resulting in model outputs that are spotty.  I attempted running the conversion tool outside of the model and continue to get the same result.  I thought their might be something in the Environment Settings but can't figure out what it is.  Previously, the model ran seamlessly so I don't what has changed to make the tool function like this.  Thanks!

-Justin
0 Kudos
SteveLynch
Esri Regular Contributor
Justin

Snap Raster would fix your problem.

If you set the output extent it means that there is a good change that the output raster's origin will shift.

You can test this, set the output extent = polygon FC and run SA's Plus tool and add 0 (zero) to your raster and see where the output raster draws. Now repeat this and use Snap Raster.

Therefore, good idea, set the Snap Raster = input raster when changing the extent.

-Steve
0 Kudos