How do I get the clipping extent right?

589
4
Jump to solution
11-20-2018 09:22 PM
NathanFleischman
New Contributor III

I used the Clip tool in Data Management toolbox to clip some rasters using a raster as the clip features. I was wondering how do you make it so that the resulting raster has the same extent as the clip features if they are diagonal. For some reason, there are parts outside of the extent that are kept as a result of the output extent. Is there a solution that might work?

Tags (3)
0 Kudos
1 Solution

Accepted Solutions
DanPatterson_Retired
MVP Esteemed Contributor

Extract by Mask—Help | ArcGIS Desktop 

If you are using a polygon layer, convert it to a raster using the same cell size and using the raster as the snap raster to ensure cell alignment.

Snap Raster (Environment setting)—Geoprocessing | ArcGIS Desktop 

Everything outside the mask will be changed to nodata.

View solution in original post

4 Replies
DanPatterson_Retired
MVP Esteemed Contributor

Extract by Mask—Help | ArcGIS Desktop 

If you are using a polygon layer, convert it to a raster using the same cell size and using the raster as the snap raster to ensure cell alignment.

Snap Raster (Environment setting)—Geoprocessing | ArcGIS Desktop 

Everything outside the mask will be changed to nodata.

NathanFleischman
New Contributor III

I came to the same conclusion.

0 Kudos
NathanFleischman
New Contributor III

Now, I am trying to get rid of extra cells that were left behind.

0 Kudos
DanPatterson_Retired
MVP Esteemed Contributor

outside the extract by mask area?

just try setting your extent to the extent of the mask, during the process or after (then copy raster to a new on so you can assess the result)

0 Kudos