Generate Near Table tool not finishing on single feature

261
2
Jump to solution
07-29-2013 12:15 PM
MikeLouwrens
Occasional Contributor III
I am trying to use the Generate Near Table tool to find the nearest polygon (within 50 metres) from points.  If I run on the entire points feature class the Generate Near Table tool produces the expected output, same as if I select multiple points.


However, if I select a single point, the Generate Near Table tool never finishes (it takes seconds on the entire point dataset)


I'm running ArcGIS Desktop 10.1 Advanced SP1.  This happens when used within ArcMap on layers, or from ArcCatalog using the feature classes themselves.


I'd appreciate any help on how to get this working, as I would like to add this to a script, but at the moment I'm having to make sure there's a count > 1 for it to work.

EDIT: A bit more information - The two feature classes (point and polygon) are in SDE (9.3.1 I think).  If I put them both into a File geodatabase, the tool runs as expected.  If I put the polygon FC in the file geodatabase and leave the point FC in SDE the tool runs as expected.  However, if I put the point FC in the file geodatabase and leave the polygon FC in SDE the tool doesn't finish. 
This ONLY happens when a single feature is selected.  If multiple features selected, or tool run on all features, the tool completes successfully.

Thanks,
Mike.
0 Kudos
1 Solution

Accepted Solutions
deleted-user-VeC5jUIlNXtq
Occasional Contributor III
Read about "NIM085504" in this: http://downloads.esri.com/support/downloads/other_/102-IssuesAddressedList.pdf

Could that perhaps be the issue? 10.2 is resolving an issue where the Near tool isn't working properly on inputs of 1 feature.

Just came across my mind while reading the PDF a week or so ago, hopefully it answers your question.

View solution in original post

0 Kudos
2 Replies
deleted-user-VeC5jUIlNXtq
Occasional Contributor III
Read about "NIM085504" in this: http://downloads.esri.com/support/downloads/other_/102-IssuesAddressedList.pdf

Could that perhaps be the issue? 10.2 is resolving an issue where the Near tool isn't working properly on inputs of 1 feature.

Just came across my mind while reading the PDF a week or so ago, hopefully it answers your question.
0 Kudos
MikeLouwrens
Occasional Contributor III
Read about "NIM085504" in this: http://downloads.esri.com/support/downloads/other_/102-IssuesAddressedList.pdf

Could that perhaps be the issue? 10.2 is resolving an issue where the Near tool isn't working properly on inputs of 1 feature.

Just came across my mind while reading the PDF a week or so ago, hopefully it answers your question.
That looks like it might be the problem - restricting the Near search to 50m is limiting the features to one point and one polygon.  Removing the 50m radius means the tool now completes.  Hopefully I can get the update soon so I can return the 50m restriction (I've added a select and delete based on any feature > 50m, which gives the same result but takes a bit longer to process).

Cheers,
Mike.
0 Kudos