Export to CAD features are not same size as in GIS

16821
11
Jump to solution
12-23-2014 10:14 AM
CherylTrine
Occasional Contributor II

I'm using ArcMap 10.2.2.  I have a line feature class that was originally created from a CAD drawing.  When I export this line feature class back to CAD, the .dwg has the wrong length for the lines when looked at in AutoCAD but not when looked at in GIS.

 

I am not sure if there is something in my workflow that is causing this, but here is what I do:  The original CAD is brought into ArcMap, georeferenced, and then the spatial reference that I work in is assigned to it.  Then I export it to geodatabase feature classes.  The line lengths of the original CAD drawing when looked at in AutoCAD are the same as the line lengths when looked at in ArcMAP, and the GISfeature class line lengths are the same as the original CAD drawing.  (Everythings good up to this point.)  However, when I use the Export to CAD tool, the resulting .dwg has line lengths that are much shorter (a 76' line becomes a 6') when looked at in AutoCAD (when looked at in GIS it is fine).  What am I doing wrong, or what should I be doing?

 

Thanks,

 

Cheryl

0 Kudos
1 Solution

Accepted Solutions
CherylTrine
Occasional Contributor II

Finally I have hit upon a solution.  If I reproject the feature classes that I want to export to CAD into a custom coordinate system in which the units are changed from feet to inches, then everything exports correctly.  The seed file, as it came from CAD, didn't need any units changed.  The block inserts exported at the proper size relative to the line features, without using a scale factor of 0.08333, and a 76' line in the GIS exports as a 76' line in CAD.

If anyone knows a better way to do this, I would like to hear about it.

Cheryl

View solution in original post

11 Replies
TobiasFimpel1
Occasional Contributor III

Try setting your data frame's coordinate system to the coordinate system of the feature class and then do the Export to CAD tool.

0 Kudos
CherylTrine
Occasional Contributor II

Unfortunately, that is not the problem.  The data frame and feature class do have the same coordinate system.

Any other ideas?

0 Kudos
TobiasFimpel1
Occasional Contributor III

Maybe the problem is that AutoCAD is looking at it the 'wrong' way. Turns out that 76 inches are 6.3 feet. So perhaps you need to change an AutoCAD setting to "units = feet" instead of inches. I'm not an AutoCAD guru, but if you have difficulties finding out how to change that I can do a bit of research/ask around.

CherylTrine
Occasional Contributor II

Yes!   Thanks a lot. That is exactly the problem, because when I convert the more exact measures from my diagram, CAD is exactly converting them as if from inches to feet.

I am no CAD guru either.  I can barely find my way around to turn layers on and off!  I wonder how to get ArcGIS to export with the proper units?

TobiasFimpel1
Occasional Contributor III

"I wonder how to get ArcGIS to export with the proper units?" That may be the right question to ask, but it may also be the wrong one. Without seeing the data I can't say for sure, but you may need to ask the question 'how to configure AutoCAD to measure with the proper units.'

0 Kudos
CherylTrine
Occasional Contributor II

I'm getting a little closer; it has to do with the seed file which contains my Block definitions.  When I export without using the seed file, the units are correct (of course the Inserts are worthless since there is no block definition)

The seed file was created from the original CAD drawing by deleting everything in the graphics area (i.e., the drawing).  There must be some units parameter in the seed file that is causing problems.

0 Kudos
TobiasFimpel1
Occasional Contributor III

Yes, you are correct. Like all AutoCAD drawings your seed file contains a unit parameter. Find and correct that parameter and your problem will be solved - nice work!

0 Kudos
CherylTrine
Occasional Contributor II

Well, I can sort of make things work, but it is far from ideal!

In the seed file, the original <Length Type> was set to Architectural and <Insertion scale> was set to inches.  If I go to Format>Units, and change the <Length Type> to Decimal or Fractional and the <Insertion scale> to Feet, the resulting dwg correctly displays the value, however without  ' or " symbols.  If I then change the <Length Type> in the resulting dwg to Architectural, it reverts to using the values as inches and converting them to feet, so back to 6'.

0 Kudos
CherylTrine
Occasional Contributor II

Thanks, Tobias, for getting me headed in the right direction.

I previously posted on an issue with Block inserts that is directly related to this one:

https://community.esri.com/message/445550#445550

"ArcGIS to AutoCAD scaling of Block inserts"

By trial and error I found if I set the scale x, scale y and scale z  to 0.08333 on my point Insert features in the GIS, they would appear at the same scale as the rest of the dwg drawing.  I didn't recognize that 0.08333 is the same as 1/12!

So now my question is, how do I change the seed file so that everything comes out right?   As mentioned above, I tried changing the units in Format with rather poor results.  Other ideas?

0 Kudos